summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nodejs/nodejs-13.9.0.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-13.9.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-libs/nodejs/nodejs-13.9.0.ebuild b/net-libs/nodejs/nodejs-13.9.0.ebuild
index 4d35b0880936..00513e8978c4 100644
--- a/net-libs/nodejs/nodejs-13.9.0.ebuild
+++ b/net-libs/nodejs/nodejs-13.9.0.ebuild
@@ -105,7 +105,11 @@ src_configure() {
use inspector || myconf+=( --without-inspector )
use npm || myconf+=( --without-npm )
use snapshot || myconf+=( --without-node-snapshot )
- use ssl && ( use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) ) || myconf+=( --without-ssl )
+ if use ssl; then
+ use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store )
+ else
+ myconf+=( --without-ssl )
+ fi
local myarch=""
case ${ABI} in