summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/weechat/weechat-9999.ebuild')
-rw-r--r--net-irc/weechat/weechat-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index da163740534f..2c9d55e5b29e 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -107,7 +107,6 @@ src_configure() {
"-DENABLE_DEMO=OFF"
"-DENABLE_GTK=OFF"
"-DENABLE_JAVASCRIPT=OFF"
- "-DPYTHON_EXECUTABLE=${PYTHON}"
$(cmake-utils_use_enable alias)
$(cmake-utils_use_enable doc)
$(cmake-utils_use_enable charset)
@@ -131,7 +130,14 @@ src_configure() {
$(cmake-utils_use_enable trigger)
$(cmake-utils_use_enable xfer)
)
- [[ ${EPYTHON} == python3* ]] && mycmakeargs+=( $(cmake-utils_use_enable python PYTHON3) )
+
+ if use python; then
+ python_export PYTHON_LIBPATH
+ mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_LIBRARY="${PYTHON_LIBPATH}"
+ )
+ fi
cmake-utils_src_configure
}