summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/toxic')
-rw-r--r--net-im/toxic/Manifest1
-rw-r--r--net-im/toxic/metadata.xml2
-rw-r--r--net-im/toxic/toxic-0.8.0-r1.ebuild92
3 files changed, 0 insertions, 95 deletions
diff --git a/net-im/toxic/Manifest b/net-im/toxic/Manifest
index 8a0a28cd3b76..2f4c4e49deba 100644
--- a/net-im/toxic/Manifest
+++ b/net-im/toxic/Manifest
@@ -1,4 +1,3 @@
-DIST toxic-0.8.0.tar.gz 1145799 BLAKE2B 01dd14d28feac0aadd1e87d8538910601b532e8cb02219091a863502eb80f812a034eecf06f131ff878509dfc1eb40e5f9baf7547180346eeb03bdb7dea4a6ed SHA512 3c59edb61b1bcdbfa3a8391a1a1ceccc6c9c38b49c1709813d60480b180fb39607806116b9dcd1de35ebb02e23e95d78c8191f04a4875e06e27fa43bc9800b33
DIST toxic-0.8.2.tar.gz 1146526 BLAKE2B 0a1c80313963287e88aa489ecf4614365a3d94c770cdfb3b1f3afd0bf2b70639c35b9c5ce52408647abdaac9822c9529b603ec1883779f5486ff63001d98ff5e SHA512 258e873404315c9a1f59d67f524089afebad88d800116bd9e53c8bc35bd9dd6b66cfcd90db06181f01330ba0a302456510fac5c01fdbfde7d475aa5d6b1070aa
DIST toxic-0.8.3.tar.gz 1147100 BLAKE2B d73a861112aca65e54773c98473c2858bb81e63fef11212633e34dac9e87101956e3ab0d9d56757767bc5d48d1d5a406e550f8fc55ae34860dbc4977c94ee347 SHA512 c8d746efcc055592dd990dfa57415cc1eacaaa3b66303d7583d9f9e7e98b8829c8f1ae849f36a243c8896e99787dd2e493c92367de719b20a4a160bc7daea76e
DIST toxic_patches-0.8.2.tar.gz 3859 BLAKE2B 4a19226cea6c7ce60f599fbd4f74171f26b3812259f0f8997997526bde7beb6fe64b922f25fe77e0ac8f9b185db116d2e626cb889631a1508786b92f9bbc8927 SHA512 737cc53e814567e10ad8b7431be63ab8f99b76bb150490c31e03309c4e51ee34a798d141cbde446cbbc4b5c0145ca468f3456a2af4b966c80792cdccc6562b46
diff --git a/net-im/toxic/metadata.xml b/net-im/toxic/metadata.xml
index 0ba52a98e62a..02e709980dad 100644
--- a/net-im/toxic/metadata.xml
+++ b/net-im/toxic/metadata.xml
@@ -20,9 +20,7 @@
An ncurses-based Tox client written in C. Supports audio and video calling, file sharing, and desktop notifications.
</longdescription>
<use>
- <flag name="audio">Enables audio calling</flag>
<flag name="notification">Enables desktop notifications with libnotify, with sound support.</flag>
- <flag name="notifications">Enables desktop notifications with libnotify, with sound support.</flag>
<flag name="qrcode">Enables QR code support</flag>
<flag name="sound">Enables audio calling</flag>
<flag name="video">Enables video calling</flag>
diff --git a/net-im/toxic/toxic-0.8.0-r1.ebuild b/net-im/toxic/toxic-0.8.0-r1.ebuild
deleted file mode 100644
index e9a1018aa90b..000000000000
--- a/net-im/toxic/toxic-0.8.0-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
-
-inherit python-single-r1 xdg
-
-DESCRIPTION="A curses-based client for Tox."
-HOMEPAGE="https://github.com/JFreegman/toxic"
-SRC_URI="https://github.com/JFreegman/toxic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+X +audio notifications +python +qrcode +video"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-# Not a typo; net-libs/tox only has a 'both or neither' option
-RDEPEND="
- || (
- audio? ( net-libs/tox:0/0.1[av] )
- video? ( net-libs/tox:0/0.1[av] )
- net-libs/tox:0/0.1
- )
- dev-libs/libconfig
- net-misc/curl:0=
- sys-libs/ncurses:0=
- audio? ( media-libs/openal media-libs/freealut )
- video? ( media-libs/libvpx:= x11-libs/libX11 )
- notifications? ( x11-libs/libnotify )
- python? ( ${PYTHON_DEPS} )
- qrcode? ( media-gfx/qrencode )
-"
-DEPEND="
- virtual/pkgconfig
- ${RDEPEND}
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-verbose-build-log.patch"
- )
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- # bug 630370: version string correction 0.7.2 -> 0.8.0
- # REMOVE THIS FOR toxic != 0.8.0
- sed -i \
- -e 's/^\(TOXIC_VERSION =\).*$/\1 0.8.0/' \
- cfg/global_vars.mk || die "Version string correction failed."
-}
-
-src_configure() {
- export USER_CFLAGS="${CFLAGS}"
- export USER_LDFLAGS="${LDFLAGS}"
- if ! use video && ! use audio; then
- export DISABLE_AV=1
- fi
- if ! use audio; then
- export DISABLE_SOUND_NOTIFY=1
- fi
- if ! use X; then
- export DISABLE_X11=1
- fi
- if ! use notifications; then
- export DISABLE_DESKTOP_NOTIFY=1
- fi
- if ! use qrcode; then
- export DISABLE_QRPNG=1
- fi
- if use python; then
- export ENABLE_PYTHON=1
- fi
- sed -i \
- -e "s,/usr/local,${EPREFIX}/usr,g" \
- cfg/global_vars.mk || die "PREFIX sed failed"
-}
-
-src_compile() {
- emake V=1 || die "emake failed"
-}
-
-src_install() {
- default
- if ! use audio; then
- rm -r "${ED%/}"/usr/share/${PN}/sounds || die "Could not remove sounds directory"
- fi
-}