summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/openvas-libraries')
-rw-r--r--net-analyzer/openvas-libraries/openvas-libraries-8.0.5.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/net-analyzer/openvas-libraries/openvas-libraries-8.0.5.ebuild b/net-analyzer/openvas-libraries/openvas-libraries-8.0.5.ebuild
index e279652477ff..988e909151bc 100644
--- a/net-analyzer/openvas-libraries/openvas-libraries-8.0.5.ebuild
+++ b/net-analyzer/openvas-libraries/openvas-libraries-8.0.5.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit cmake-utils
+EAPI=7
DL_ID=2191
+inherit cmake-utils
DESCRIPTION="A remote security scanner for Linux (openvas-libraries)"
HOMEPAGE="http://www.openvas.org/"
@@ -16,23 +15,26 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="ldap"
-RDEPEND="
+DEPEND="
app-crypt/gpgme
>=dev-libs/glib-2.16
>=dev-libs/hiredis-0.10.1
dev-libs/libgcrypt:0
dev-libs/libksba
- !net-analyzer/openvas-libnasl
+ net-analyzer/net-snmp
net-libs/gnutls
net-libs/libpcap
>=net-libs/libssh-0.5.0
- net-analyzer/net-snmp
- ldap? ( net-nds/openldap )"
-DEPEND="${RDEPEND}
+ ldap? ( net-nds/openldap )
+"
+RDEPEND="${DEPEND}
+ !net-analyzer/openvas-libnasl
+"
+BDEPEND="
sys-devel/bison
sys-devel/flex
virtual/pkgconfig
- "
+"
S="${WORKDIR}"/${P}
@@ -42,13 +44,13 @@ PATCHES=(
"${FILESDIR}"/${PN}-7.0.4-libssh.patch
"${FILESDIR}"/${PN}-8.0.1-include.patch
"${FILESDIR}"/${P}-underlinking.patch
- )
+)
src_prepare() {
+ cmake-utils_src_prepare
sed \
-e '/^install.*OPENVAS_CACHE_DIR.*/d' \
-i CMakeLists.txt || die
- cmake-utils_src_prepare
}
src_configure() {