summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/sweep/files/sweep-0.9.3-configure.patch')
-rw-r--r--media-sound/sweep/files/sweep-0.9.3-configure.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/sweep/files/sweep-0.9.3-configure.patch b/media-sound/sweep/files/sweep-0.9.3-configure.patch
new file mode 100644
index 000000000000..38c8717c4cdd
--- /dev/null
+++ b/media-sound/sweep/files/sweep-0.9.3-configure.patch
@@ -0,0 +1,53 @@
+--- sweep-0.9.3/configure.ac.orig
++++ sweep-0.9.3/configure.ac
+@@ -137,13 +137,13 @@
+
+ ac_enable_oggvorbis=yes
+ AC_ARG_ENABLE(oggvorbis,
+- [ --disable-oggvorbis disable Ogg Vorbis support],
+- [ ac_enable_oggvorbis=no ], [ ac_enable_oggvorbis=yes ])
++ [ --enable-oggvorbis enable Ogg Vorbis support],
++ [ ac_enable_oggvorbis=yes ], [ ac_enable_oggvorbis=no ])
+
+ ac_enable_speex=yes
+ AC_ARG_ENABLE(speex,
+- [ --disable-speex disable Speex support],
+- [ ac_enable_speex=no ], [ ac_enable_speex=yes ])
++ [ --enable-speex enable Speex support],
++ [ ac_enable_speex=yes ], [ ac_enable_speex=no ])
+
+ dnl Both Vorbis and Speex require Ogg, so check for it first either way
+ if test "x${ac_enable_oggvorbis}" != xno ||
+@@ -274,8 +274,8 @@
+
+ ac_enable_mad=yes
+ AC_ARG_ENABLE(mad,
+- [ --disable-mad disable libmad (MPEG audio loading) support],
+- [ ac_enable_mad=no ], [ ac_enable_mad=yes ])
++ [ --enable-mad enable libmad (MPEG audio loading) support],
++ [ ac_enable_mad=yes ], [ ac_enable_mad=no ])
+
+ if test "x${ac_enable_mad}" != xno ; then
+ AC_CHECK_LIB(mad, mad_decoder_init, HAVE_MAD="maybe")
+@@ -301,8 +301,8 @@
+
+ ac_enable_src=yes
+ AC_ARG_ENABLE(src,
+- [ --disable-src enable secret rabbit code (libsamplerate)],
+- [ ac_enable_src=no ], [ ac_enable_src=yes])
++ [ --enable-src enable secret rabbit code (libsamplerate)],
++ [ ac_enable_src=yes ], [ ac_enable_src=no])
+
+ if test "x${ac_enable_src}" != xno ; then
+ PKG_CHECK_MODULES(SAMPLERATE, samplerate >= 0.0.9,
+@@ -324,8 +324,8 @@
+
+ ac_enable_alsa=yes
+ AC_ARG_ENABLE(alsa,
+- [ --disable-alsa Disable ALSA, and enable use of OSS],
+- [ ac_enable_alsa=no ])
++ [ --enable-alsa enable ALSA support],
++ [ ac_enable_alsa=yes ], [ ac_enable_alsa=no ])
+
+ if test "x${ac_enable_alsa}" != xno ; then
+