summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/KochMorse/KochMorse-3.4.0.ebuild27
-rw-r--r--media-radio/KochMorse/Manifest1
-rw-r--r--media-radio/KochMorse/metadata.xml15
3 files changed, 41 insertions, 2 deletions
diff --git a/media-radio/KochMorse/KochMorse-3.4.0.ebuild b/media-radio/KochMorse/KochMorse-3.4.0.ebuild
new file mode 100644
index 000000000000..eee17a4fe396
--- /dev/null
+++ b/media-radio/KochMorse/KochMorse-3.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Morse-code tutor using the Koch method"
+HOMEPAGE="https://github.com/hmatuschek/kochmorse"
+SRC_URI="https://github.com/hmatuschek/kochmorse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtmultimedia"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools
+ dev-util/cmake[qt5]"
+
+S="${WORKDIR}/kochmorse-${PV}"
+
+src_prepare() {
+ sed -i -e 's/Teaching;/X-Teaching;/' shared/kochmorse.desktop || die
+ eapply_user
+}
diff --git a/media-radio/KochMorse/Manifest b/media-radio/KochMorse/Manifest
index 6ce84dcc6968..49d1719ca3dd 100644
--- a/media-radio/KochMorse/Manifest
+++ b/media-radio/KochMorse/Manifest
@@ -1 +1,2 @@
DIST KochMorse-0.99.6.tar.gz 30497 BLAKE2B b6c40378f1e105f3010a5d703f910ae7c2216da5892f65c85cb2b56227f38d9e88d49fac38ed3ab8513cae45dfb5bb0474fab420b8151b028061392f7e657dfd SHA512 0803f3fb092962bebffccac143dd4410330d529ec1fe3a8a0c377f640349e0a8f5c254772c5ed7e63cf63c47ce14f304658b4870c78cf89c391823c93ab9b005
+DIST KochMorse-3.4.0.tar.gz 1066631 BLAKE2B a435ab85ea782cb09ceab23109651572a2ed8fab6764ed54cdb5c1f2a51814f477fca013913f81b806404abf0d210edce7cca589b10b19b39fece5d8e1f7b581 SHA512 43cf5c3c9d66c4ef23016246a80ab426976a20ca5a2639d47ff2622adcaa3a9444dbfcd2d5c28c5ee32e0f041e8ecd8a33f82a9ed3040753699ebbb43d8f0faa
diff --git a/media-radio/KochMorse/metadata.xml b/media-radio/KochMorse/metadata.xml
index 2dd58bbfe603..9db9e59f2d8e 100644
--- a/media-radio/KochMorse/metadata.xml
+++ b/media-radio/KochMorse/metadata.xml
@@ -1,8 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>gentoo@seichter.de</email>
+ <name>Ralph Seichter</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ KochMorse is a simple morse-code tutor using the Koch method. It is
+ written in C++ and uses Qt5 for the graphical user interface.
+ </longdescription>
<upstream>
- <remote-id type="google-code">KochMorse</remote-id>
+ <remote-id type="github">hmatuschek/kochmorse</remote-id>
</upstream>
</pkgmetadata>