summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gmmlib')
-rw-r--r--media-libs/gmmlib/gmmlib-22.3.4-r1.ebuild (renamed from media-libs/gmmlib/gmmlib-22.3.4.ebuild)4
-rw-r--r--media-libs/gmmlib/gmmlib-9999.ebuild6
2 files changed, 5 insertions, 5 deletions
diff --git a/media-libs/gmmlib/gmmlib-22.3.4.ebuild b/media-libs/gmmlib/gmmlib-22.3.4-r1.ebuild
index 97335b7ca360..21abbf34e428 100644
--- a/media-libs/gmmlib/gmmlib-22.3.4.ebuild
+++ b/media-libs/gmmlib/gmmlib-22.3.4-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
CMAKE_BUILD_TYPE="Release"
-inherit cmake
+inherit cmake-multilib
DESCRIPTION="Intel Graphics Memory Management Library"
HOMEPAGE="https://github.com/intel/gmmlib"
@@ -24,7 +24,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
)
-src_configure() {
+multilib_src_configure() {
local mycmakeargs=(
-DBUILD_TESTING="$(usex test)"
-DBUILD_TYPE="Release"
diff --git a/media-libs/gmmlib/gmmlib-9999.ebuild b/media-libs/gmmlib/gmmlib-9999.ebuild
index 7042078bafaa..88b7feadef4d 100644
--- a/media-libs/gmmlib/gmmlib-9999.ebuild
+++ b/media-libs/gmmlib/gmmlib-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
CMAKE_BUILD_TYPE="Release"
-inherit cmake
+inherit cmake-multilib
if [[ ${PV} == *9999 ]] ; then
: ${EGIT_REPO_URI:="https://github.com/intel/gmmlib"}
@@ -30,7 +30,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
)
-src_configure() {
+multilib_src_configure() {
local mycmakeargs=(
-DBUILD_TESTING="$(usex test)"
-DBUILD_TYPE="Release"