summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mutt-wizard/Manifest1
-rw-r--r--mail-client/mutt-wizard/mutt-wizard-3.1.1.ebuild46
-rw-r--r--mail-client/mutt-wizard/mutt-wizard-9999.ebuild6
3 files changed, 49 insertions, 4 deletions
diff --git a/mail-client/mutt-wizard/Manifest b/mail-client/mutt-wizard/Manifest
index 8a91ae2de623..bbade360d27f 100644
--- a/mail-client/mutt-wizard/Manifest
+++ b/mail-client/mutt-wizard/Manifest
@@ -1 +1,2 @@
DIST mutt-wizard-0_pre20200808.tar.gz 30797 BLAKE2B 90b7382b6d2a687fa2ce5b267a00ee582c1ea89169185eb556f7e3aab4bbc822068fd691fbdaa843df0c525ec737a34acb39bc8a09d3c608837487825e57344b SHA512 e49de65658d4222d8932b1dd117631fffcd08493dc6e20a5157f8a3e336e179bf754ef64387f2b538c70898183a0413c99425a2751debb4b8d7cea5465076f57
+DIST mutt-wizard-3.1.1.tar.gz 33346 BLAKE2B 0f4d8e973fedc0d102242a06922627039f4244ad9fc901d6e3d7235089164c3a7f255587978c95762242146441d8a48f57401e9ec86754194b531d38f0074652 SHA512 b385bab603eff561bca8aade49f3d11a4ac031cbceb4a64d80be9b591dc34757a05bb3c56c23ec9f1942392833725872d4871bf34964c4503bc01d5223286ddb
diff --git a/mail-client/mutt-wizard/mutt-wizard-3.1.1.ebuild b/mail-client/mutt-wizard/mutt-wizard-3.1.1.ebuild
new file mode 100644
index 000000000000..dc33b5c31681
--- /dev/null
+++ b/mail-client/mutt-wizard/mutt-wizard-3.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature
+
+DESCRIPTION="A system for automatically configuring neomutt and isync"
+HOMEPAGE="https://github.com/LukeSmithxyz/mutt-wizard"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LukeSmithxyz/mutt-wizard.git"
+else
+ SRC_URI="https://github.com/LukeSmithxyz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-admin/pass
+ mail-client/neomutt[notmuch]
+ mail-mta/msmtp
+ net-mail/isync[ssl]
+"
+
+# needed because there is no 'all' target defined in MAKEFILE
+src_compile() {
+ return 0;
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "enable viewing html mails" www-client/lynx
+ optfeature "enable periodic syncing of mails" virtual/cron
+ optfeature "enable viewing of simple images" media-gfx/imagemagick
+ optfeature "enable notifications when syncing using mailsync" x11-libs/libnotify
+ optfeature "enable command line address book" app-misc/abook
+ optfeature "enable use of gpg for signing and verifying" app-crypt/gnupg
+}
diff --git a/mail-client/mutt-wizard/mutt-wizard-9999.ebuild b/mail-client/mutt-wizard/mutt-wizard-9999.ebuild
index 995d3d16cda8..dc33b5c31681 100644
--- a/mail-client/mutt-wizard/mutt-wizard-9999.ebuild
+++ b/mail-client/mutt-wizard/mutt-wizard-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,10 +12,8 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/LukeSmithxyz/mutt-wizard.git"
else
- COMMIT=9ec2a49af03cf542c7db82bc0dd0ccdde81922d4
- SRC_URI="https://github.com/LukeSmithxyz/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/LukeSmithxyz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${PN}-${COMMIT}"
fi
LICENSE="GPL-3"