summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.12.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 563bc5231b93..a94d2a0f7065 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.11.5.tar.xz 19060 BLAKE2B 814199f67c9026ca420c66d0dbe48ef9f1cab2d30bf3784cb3441af56ceec9ab3841dcf41021bbc5d42edffc0fc0849b714c1f279065c974bba794924fc0879c SHA512 1602ef0eeec86c653c2a99c1c514133367e7dee07d11ffbe0533066d895c71e3b7dd90187cb353446b717738600143cd09de1a5baffad5113152fd616bef90ee
DIST kwallet-pam-5.12.1.tar.xz 18484 BLAKE2B c44033e90be594f858913afbd20bd8254c6dec7b695cdfa79265c2f069e28b3457238f3e4df9a2a3cd37bc6d709d087d3f4bf09239ec37fabda7b1edc44d1bbe SHA512 c5bd45b2dc6d0637610fea48b93ab9bb9068bc96ccd5f41a537b8f41db9f3d35bc5c1edd510885735e2605a93ed166cc7b5f979ffe48e6fc3af26f81cc822d08
+DIST kwallet-pam-5.12.2.tar.xz 18584 BLAKE2B 19a0dbe21d6c29521aace4147429c13f365f6e235a79a337a38f5c0fc9b62837ff8105058bf8aacca726f146876f6e8753d80679f50a80ba2bfb0f1b8563e025 SHA512 2e408314031b937d28b949634529dc77e3543f8dddc303abdc4ca4a90a1bcbf315398c112483c266ca346363107218cd74469826aa9af68ce5ce7703859d09db
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.12.2.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.12.2.ebuild
new file mode 100644
index 000000000000..8c9a7437fc09
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.12.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ virtual/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ -DKWALLET4=0
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}