summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/metadata.xml1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.62.0.ebuild42
3 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index 7046253ad313..105cc15ca324 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1,2 +1,3 @@
DIST sonnet-5.60.0.tar.xz 287516 BLAKE2B 1500c4e978205a70b68a0f59a4767980544c9f380a3286f2c6072d98cd61f0e986a996df602680e782b46b791e3e2feaf3b6076b56219a3f15ee0d137124a674 SHA512 2dbb3bec5f0999b82a09c9ff9a826cb390dfae55d91f4ae91ed494a41d498ec18a5bfb53ecd95f6b086bd2f0b72f6ffbcc690aefe8de1e2e6694ec8750230441
DIST sonnet-5.61.0.tar.xz 286520 BLAKE2B 4fecfc69603c8d63942e7b92bc92691d82e5eca2d093812ad3c86015eee0e0e29746bbc6561b81339acbe42d9e38f737800bc665819945636fd3277dc93fa550 SHA512 8917ca9207715e308080c9f68107a97d234a1aa95fffa85712c413a51493010fc52e0e39c618c3d8290a9731d07b343d8349f383428cce8358a662ddc8698b97
+DIST sonnet-5.62.0.tar.xz 287308 BLAKE2B 7f644a36104d43a03d73a26bbadb8a81f47e5ebdabf1fe735fc07f7130d5bbea365decbb7d6706778693297ae46c50449bb18363c49b04c91eea2a78a8380411 SHA512 e0c8c78fef8e2de3160bd54922541e3d3bc9a4dc016a6695bf6ff2c0579d5b42986fa9bfd845a240c9d0da73f6c3cfa11af6fa7cb93db7ce6c956b766dbd94e3
diff --git a/kde-frameworks/sonnet/metadata.xml b/kde-frameworks/sonnet/metadata.xml
index 35e3f37b3a0f..0d422498d83c 100644
--- a/kde-frameworks/sonnet/metadata.xml
+++ b/kde-frameworks/sonnet/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="aspell">Enable the app-text/aspell spell-checking backend</flag>
+ <flag name="designer">Build plugins for <pkg>dev-qt/designer</pkg></flag>
<flag name="hunspell">Enable the app-text/hunspell spell-checking backend</flag>
</use>
</pkgmetadata>
diff --git a/kde-frameworks/sonnet/sonnet-5.62.0.ebuild b/kde-frameworks/sonnet/sonnet-5.62.0.ebuild
new file mode 100644
index 000000000000..cbb75a608688
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.62.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_DESIGNERPLUGIN="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+DEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell ASPELL)
+ $(cmake-utils_use_find_package hunspell HUNSPELL)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ # bugs: 680032
+ local myctestargs=(
+ -E "(sonnet-test_settings|sonnet-test_highlighter)"
+ )
+
+ kde5_src_test
+}