summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kded/kded-5.16.0.ebuild')
-rw-r--r--kde-frameworks/kded/kded-5.16.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-frameworks/kded/kded-5.16.0.ebuild b/kde-frameworks/kded/kded-5.16.0.ebuild
new file mode 100644
index 000000000000..0975e7afb75b
--- /dev/null
+++ b/kde-frameworks/kded/kded-5.16.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Central daemon of KDE workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="+man"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kservice)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}