summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/libkcddb/libkcddb-4.14.3.ebuild')
-rw-r--r--kde-apps/libkcddb/libkcddb-4.14.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/kde-apps/libkcddb/libkcddb-4.14.3.ebuild b/kde-apps/libkcddb/libkcddb-4.14.3.ebuild
new file mode 100644
index 000000000000..a971e107aad6
--- /dev/null
+++ b/kde-apps/libkcddb/libkcddb-4.14.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE library for CDDB"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug musicbrainz"
+
+# tests require network access and compare static data with online data
+# bug 280996
+RESTRICT=test
+
+DEPEND="
+ musicbrainz? ( media-libs/musicbrainz:5 )
+"
+RDEPEND="${DEPEND}"
+
+KMSAVELIBS="true"
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if ! use handbook ; then
+ pushd kcmcddb > /dev/null
+ comment_add_subdirectory doc
+ popd > /dev/null
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with musicbrainz MusicBrainz5)
+ )
+
+ kde4-base_src_configure
+}