summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/adonthell')
-rw-r--r--games-rpg/adonthell/adonthell-0.3.8.ebuild8
-rw-r--r--games-rpg/adonthell/files/adonthell-0.3.8-python3.10.patch7
2 files changed, 11 insertions, 4 deletions
diff --git a/games-rpg/adonthell/adonthell-0.3.8.ebuild b/games-rpg/adonthell/adonthell-0.3.8.ebuild
index 55a6d24270f2..4a48d53e89f0 100644
--- a/games-rpg/adonthell/adonthell-0.3.8.ebuild
+++ b/games-rpg/adonthell/adonthell-0.3.8.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit autotools python-single-r1
DESCRIPTION="Roleplaying game engine"
@@ -39,7 +38,8 @@ BDEPEND="
DOCS=( AUTHORS NEWBIE NEWS README )
PATCHES=(
- "${FILESDIR}/${P}-ar.patch"
+ "${FILESDIR}"/${P}-ar.patch
+ "${FILESDIR}"/${P}-python3.10.patch
)
src_prepare() {
diff --git a/games-rpg/adonthell/files/adonthell-0.3.8-python3.10.patch b/games-rpg/adonthell/files/adonthell-0.3.8-python3.10.patch
new file mode 100644
index 000000000000..21bba839a271
--- /dev/null
+++ b/games-rpg/adonthell/files/adonthell-0.3.8-python3.10.patch
@@ -0,0 +1,7 @@
+node.h was removed in python3.10 but this does not actually use it
+--- a/src/python_class.h
++++ b/src/python_class.h
+@@ -38,3 +38,2 @@
+ #include "eval.h"
+-#include "node.h"
+ #include "fileops.h"