summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/world-of-goo-gog/world-of-goo-gog-1.51.29337.ebuild')
-rw-r--r--games-puzzle/world-of-goo-gog/world-of-goo-gog-1.51.29337.ebuild44
1 files changed, 22 insertions, 22 deletions
diff --git a/games-puzzle/world-of-goo-gog/world-of-goo-gog-1.51.29337.ebuild b/games-puzzle/world-of-goo-gog/world-of-goo-gog-1.51.29337.ebuild
index 15ac77073cfd..af12c0ed1fc3 100644
--- a/games-puzzle/world-of-goo-gog/world-of-goo-gog-1.51.29337.ebuild
+++ b/games-puzzle/world-of-goo-gog/world-of-goo-gog-1.51.29337.ebuild
@@ -3,58 +3,58 @@
EAPI=7
-inherit desktop eutils # eutils for make_wrapper()
+inherit desktop unpacker xdg
MY_PN="WorldOfGoo"
DESCRIPTION="A puzzle game with a strong emphasis on physics (GOG edition)"
-HOMEPAGE="http://2dboy.com/"
+HOMEPAGE="https://2dboy.com/"
SRC_URI="world_of_goo_${PV//./_}.sh"
LICENSE="2dboy-EULA"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bundled-libs"
-RESTRICT="fetch bindist strip bundled-libs? ( splitdebug )"
+RESTRICT="bindist fetch strip bundled-libs? ( splitdebug )"
-DEPEND="app-arch/unzip"
-RDEPEND="!bundled-libs? (
- media-libs/libsdl2[alsa,sound,opengl,video]
+BDEPEND="app-arch/unzip"
+
+RDEPEND="
+ !bundled-libs? (
+ media-libs/libsdl2[opengl,sound,video]
media-libs/sdl2-mixer[vorbis]
)
+ >=sys-devel/gcc-3.4
sys-libs/glibc
virtual/opengl
- virtual/glu
- >=sys-devel/gcc-3.4
!games-puzzle/world-of-goo
- !games-puzzle/world-of-goo-hb"
+ !games-puzzle/world-of-goo-hb
+"
dir="/opt/${PN%-*}"
-
-QA_PREBUILT="${dir:1}/${MY_PN}.bin.x86
- ${dir:1}/${MY_PN}.bin.x86_64"
+S="${WORKDIR}"
+QA_PREBUILT="${dir#/}/*"
pkg_nofetch() {
- elog "Download ${A} from www.gog.com"
- elog "and place it in your DISTDIR directory."
+ elog "Please buy and download ${A} from:"
+ elog " https://www.gog.com/game/world_of_goo"
+ elog "and move it to your distfiles directory."
}
src_unpack() {
- unzip -d "${S}" "${DISTDIR}/${A}"
+ unpack_zip ${A}
}
src_install() {
exeinto "${dir}"
- doexe data/noarch/game/${MY_PN}.bin.x86$(usex amd64 _64)
-
- make_wrapper "${PN%-*}" "${dir}"/${MY_PN}.bin.x86$(usex amd64 _64) \
- $(use bundled-libs && (printf '"%s" "%s/lib%s"' "${dir}" "${dir}" $(usex amd64 64) || die))
+ newexe data/noarch/game/${MY_PN}.bin.x86$(usex amd64 _64) ${MY_PN}.bin
+ dosym "../..${dir}"/${MY_PN}.bin /usr/bin/${PN%-*}
insinto "${dir}"
- doins -r data/noarch/game/game
- use bundled-libs && doins -r data/noarch/game/lib$(usex amd64 64)
- newicon data/noarch/game/game/gooicon.png ${PN%-*}.png
+ doins -r data/noarch/game/game/
+ use bundled-libs && doins -r data/noarch/game/lib$(usex amd64 64)/
+ newicon -s 256 data/noarch/game/gooicon.png ${PN%-*}.png
make_desktop_entry ${PN%-*} "World of Goo" ${PN%-*}
dodoc data/noarch/docs/linux-issues.txt