summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pahole/pahole-9999.ebuild')
-rw-r--r--dev-util/pahole/pahole-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/pahole/pahole-9999.ebuild b/dev-util/pahole/pahole-9999.ebuild
index 37c3f429d6d8..560c9a73d4a0 100644
--- a/dev-util/pahole/pahole-9999.ebuild
+++ b/dev-util/pahole/pahole-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit cmake python-single-r1
MY_PN=dwarves
@@ -58,7 +58,7 @@ src_unpack() {
if use verify-sig; then
einfo "Unpacking ${MY_P}.tar.xz ..."
verify-sig_verify_detached - "${DISTDIR}"/${MY_P}.tar.sign \
- < <(xz -cd "${DISTDIR}"/${MY_P}.tar.xz | tee >(tar -x))
+ < <(xz -cd "${DISTDIR}"/${MY_P}.tar.xz | tee >(tar -xf -))
assert "Unpack failed"
else
default