summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/lcov/lcov-1.13-r1.ebuild')
-rw-r--r--dev-util/lcov/lcov-1.13-r1.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-util/lcov/lcov-1.13-r1.ebuild b/dev-util/lcov/lcov-1.13-r1.ebuild
index 94b261fb04b7..687e3ec26ce3 100644
--- a/dev-util/lcov/lcov-1.13-r1.ebuild
+++ b/dev-util/lcov/lcov-1.13-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit prefix
+
DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
HOMEPAGE="http://ltp.sourceforge.net/coverage/lcov.php"
SRC_URI="mirror://sourceforge/ltp/${P}.tar.gz"
@@ -15,6 +17,13 @@ RDEPEND="
dev-lang/perl
dev-perl/GD[png]"
+src_prepare() {
+ default
+ if use prefix; then
+ hprefixify bin/*.{pl,sh}
+ fi
+}
+
src_compile() { :; }
src_install() {