summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/buildbot-worker/buildbot-worker-0.9.2-r1.ebuild')
-rw-r--r--dev-util/buildbot-worker/buildbot-worker-0.9.2-r1.ebuild93
1 files changed, 0 insertions, 93 deletions
diff --git a/dev-util/buildbot-worker/buildbot-worker-0.9.2-r1.ebuild b/dev-util/buildbot-worker/buildbot-worker-0.9.2-r1.ebuild
deleted file mode 100644
index a14d84577095..000000000000
--- a/dev-util/buildbot-worker/buildbot-worker-0.9.2-r1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
-
-[[ ${PV} == *9999 ]] && inherit git-r3
-inherit readme.gentoo user distutils-r1
-
-DESCRIPTION="BuildBot Slave Daemon"
-HOMEPAGE="http://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-worker"
-
-MY_V="${PV/_p/p}"
-MY_P="${PN}-${MY_V}"
-if [[ ${PV} != *9999 ]]; then
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz
- http://dev.gentoo.org/~dolsen/distfiles/buildbot_worker-9-tests.tar.xz"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-if [[ ${PV} == *9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64"
-fi
-IUSE="test"
-
-RDEPEND=">=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
- || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-core-8.0.0[${PYTHON_USEDEP}]
- )
- dev-python/future[${PYTHON_USEDEP}]
- !<dev-util/buildbot-0.9.0_rc1
-"
-DEPEND="${RDEPEND}
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/setuptools_trial[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_P}"
-[[ ${PV} == *9999 ]] && S=${S}/slave
-
-pkg_setup() {
- enewuser buildbot
-
- DOC_CONTENTS="The \"buildbot\" user and the \"buildbot_worker\" init script has been added
- to support starting buildbot_worker through Gentoo's init system. To use this,
- set up your build worker following the documentation, make sure the
- resulting directories are owned by the \"buildbot\" user and point
- \"${ROOT}etc/conf.d/buildbot_worker\" at the right location. The scripts can
- run as a different user if desired. If you need to run more than one
- build worker, just copy the scripts."
-}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- cd ${MY_P}
- unpack buildbot_worker-9-tests.tar.xz
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/buildbot-worker-0.9.Addmissedtests.patch
- }
-
-python_test() {
- distutils_install_for_testing
-
- esetup.py test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- doman docs/buildbot-worker.1
-
- newconfd "${FILESDIR}/buildbot_worker.confd" buildbot_worker
- newinitd "${FILESDIR}/buildbot_worker.initd" buildbot_worker
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
- ewarn "The 0.9.2 and 0.9.3 original ebuilds had a mistake naming the"
- ewarn "conf.d and init.d files as 'buildslave', when it should have been"
- ewarn "'buildbot_worker' as it is in the previous 0.9 versions."
- ewarn "Only the 0.8 and previous versions should use the name 'buildslave'"
-}