summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rspec-core/rspec-core-3.12.2.ebuild')
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.12.2.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-ruby/rspec-core/rspec-core-3.12.2.ebuild b/dev-ruby/rspec-core/rspec-core-3.12.2.ebuild
index 00fec35093f5..a27812f4aed8 100644
--- a/dev-ruby/rspec-core/rspec-core-3.12.2.ebuild
+++ b/dev-ruby/rspec-core/rspec-core-3.12.2.ebuild
@@ -77,6 +77,9 @@ all_ruby_prepare() {
# This fails when localhost resolves to ::1 which may be a
# ruby regression in the drb/acl code.
rm -f spec/rspec/core/bisect/server_spec.rb || die
+
+ # Avoid old regression check (already fixed upstream)
+ sed -i -e '/uses only one thread local variable/askip "old safety check"' spec/rspec/core_spec.rb || die
}
each_ruby_prepare() {