summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/MechanicalSoup/MechanicalSoup-1.0.0.ebuild2
-rw-r--r--dev-python/MechanicalSoup/MechanicalSoup-1.1.0.ebuild2
-rw-r--r--dev-python/bandit/bandit-1.6.2-r1.ebuild2
-rw-r--r--dev-python/bandit/bandit-1.7.0.ebuild2
-rw-r--r--dev-python/beautifulsoup4/Manifest (renamed from dev-python/beautifulsoup/Manifest)0
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild (renamed from dev-python/beautifulsoup/beautifulsoup-4.10.0.ebuild)6
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild (renamed from dev-python/beautifulsoup/beautifulsoup-4.9.3.ebuild)6
-rw-r--r--dev-python/beautifulsoup4/metadata.xml (renamed from dev-python/beautifulsoup/metadata.xml)0
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.7.0.ebuild2
-rw-r--r--dev-python/lxml/lxml-4.6.3-r1.ebuild2
-rw-r--r--dev-python/lxml/lxml-4.6.3.ebuild2
-rw-r--r--dev-python/micawber/micawber-0.5.4.ebuild2
-rw-r--r--dev-python/mkdocs-material-extensions/mkdocs-material-extensions-1.0.3.ebuild2
-rw-r--r--dev-python/pandas/pandas-1.2.3-r1.ebuild8
-rw-r--r--dev-python/pandas/pandas-1.2.4.ebuild8
-rw-r--r--dev-python/pandas/pandas-1.2.5.ebuild8
-rw-r--r--dev-python/pandas/pandas-1.3.0.ebuild8
-rw-r--r--dev-python/pandas/pandas-1.3.1.ebuild8
-rw-r--r--dev-python/pandas/pandas-1.3.2.ebuild8
-rw-r--r--dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.6.3.ebuild2
-rw-r--r--dev-python/pyquery/pyquery-1.4.3.ebuild4
-rw-r--r--dev-python/pyspelling/pyspelling-2.7.2.ebuild2
-rw-r--r--dev-python/pyspelling/pyspelling-2.7.3.ebuild2
-rw-r--r--dev-python/setuptools_rust/setuptools_rust-0.12.1.ebuild2
-rw-r--r--dev-python/soupsieve/soupsieve-2.2.1.ebuild2
-rw-r--r--dev-python/sphinx-tabs/sphinx-tabs-3.1.0.ebuild2
-rw-r--r--dev-python/webtest/webtest-2.0.35.ebuild2
-rw-r--r--dev-python/webtest/webtest-3.0.0.ebuild2
28 files changed, 45 insertions, 53 deletions
diff --git a/dev-python/MechanicalSoup/MechanicalSoup-1.0.0.ebuild b/dev-python/MechanicalSoup/MechanicalSoup-1.0.0.ebuild
index dacc96fc35c4..898b3da8d112 100644
--- a/dev-python/MechanicalSoup/MechanicalSoup-1.0.0.ebuild
+++ b/dev-python/MechanicalSoup/MechanicalSoup-1.0.0.ebuild
@@ -17,7 +17,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="examples"
RDEPEND="
- >=dev-python/beautifulsoup-4.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.0[${PYTHON_USEDEP}]
>=dev-python/six-1.4[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
diff --git a/dev-python/MechanicalSoup/MechanicalSoup-1.1.0.ebuild b/dev-python/MechanicalSoup/MechanicalSoup-1.1.0.ebuild
index 44b270442a57..31d7a461a061 100644
--- a/dev-python/MechanicalSoup/MechanicalSoup-1.1.0.ebuild
+++ b/dev-python/MechanicalSoup/MechanicalSoup-1.1.0.ebuild
@@ -17,7 +17,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="examples"
RDEPEND="
- >=dev-python/beautifulsoup-4.7[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.7[${PYTHON_USEDEP}]
>=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
"
diff --git a/dev-python/bandit/bandit-1.6.2-r1.ebuild b/dev-python/bandit/bandit-1.6.2-r1.ebuild
index e455e7f97a6a..c957733f8725 100644
--- a/dev-python/bandit/bandit-1.6.2-r1.ebuild
+++ b/dev-python/bandit/bandit-1.6.2-r1.ebuild
@@ -32,7 +32,7 @@ DEPEND="
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
>=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
>=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/beautifulsoup-4.6.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.6.0[${PYTHON_USEDEP}]
>=dev-python/pylint-1.4.5[${PYTHON_USEDEP}]
)"
RDEPEND="
diff --git a/dev-python/bandit/bandit-1.7.0.ebuild b/dev-python/bandit/bandit-1.7.0.ebuild
index 5aa40dc0dd67..917f337ff285 100644
--- a/dev-python/bandit/bandit-1.7.0.ebuild
+++ b/dev-python/bandit/bandit-1.7.0.ebuild
@@ -27,7 +27,7 @@ DEPEND="
>=dev-python/stestr-2.5.0
>=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
>=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/beautifulsoup-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
>=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
)"
RDEPEND="
diff --git a/dev-python/beautifulsoup/Manifest b/dev-python/beautifulsoup4/Manifest
index 4dede2d8d2dd..4dede2d8d2dd 100644
--- a/dev-python/beautifulsoup/Manifest
+++ b/dev-python/beautifulsoup4/Manifest
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.10.0.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild
index 90b5dd8cdfb7..78187c60a289 100644
--- a/dev-python/beautifulsoup/beautifulsoup-4.10.0.ebuild
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild
@@ -6,13 +6,9 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
-MY_PN="${PN}4"
-MY_P="${MY_PN}-${PV}"
-
DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="4"
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.9.3.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild
index efc93f3c7550..589f96740cb5 100644
--- a/dev-python/beautifulsoup/beautifulsoup-4.9.3.ebuild
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild
@@ -7,13 +7,9 @@ PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
-MY_PN="${PN}4"
-MY_P="${MY_PN}-${PV}"
-
DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="4"
diff --git a/dev-python/beautifulsoup/metadata.xml b/dev-python/beautifulsoup4/metadata.xml
index 227205f32598..227205f32598 100644
--- a/dev-python/beautifulsoup/metadata.xml
+++ b/dev-python/beautifulsoup4/metadata.xml
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.7.0.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.7.0.ebuild
index 72b25fc41302..6d0be009fe35 100644
--- a/dev-python/dns-lexicon/dns-lexicon-3.7.0.ebuild
+++ b/dev-python/dns-lexicon/dns-lexicon-3.7.0.ebuild
@@ -19,7 +19,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
- dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/tldextract[${PYTHON_USEDEP}]
dev-python/cryptography[${PYTHON_USEDEP}]
diff --git a/dev-python/lxml/lxml-4.6.3-r1.ebuild b/dev-python/lxml/lxml-4.6.3-r1.ebuild
index 6e745baefa10..e0ce5bad3a36 100644
--- a/dev-python/lxml/lxml-4.6.3-r1.ebuild
+++ b/dev-python/lxml/lxml-4.6.3-r1.ebuild
@@ -95,6 +95,6 @@ python_install_all() {
}
pkg_postinst() {
- optfeature "Support for BeautifulSoup as a parser backend" dev-python/beautifulsoup
+ optfeature "Support for BeautifulSoup as a parser backend" dev-python/beautifulsoup4
optfeature "Translates CSS selectors to XPath 1.0 expressions" dev-python/cssselect
}
diff --git a/dev-python/lxml/lxml-4.6.3.ebuild b/dev-python/lxml/lxml-4.6.3.ebuild
index 56111fe84a47..fc97e91c34bb 100644
--- a/dev-python/lxml/lxml-4.6.3.ebuild
+++ b/dev-python/lxml/lxml-4.6.3.ebuild
@@ -95,6 +95,6 @@ python_install_all() {
}
pkg_postinst() {
- optfeature "Support for BeautifulSoup as a parser backend" dev-python/beautifulsoup
+ optfeature "Support for BeautifulSoup as a parser backend" dev-python/beautifulsoup4
optfeature "Translates CSS selectors to XPath 1.0 expressions" dev-python/cssselect
}
diff --git a/dev-python/micawber/micawber-0.5.4.ebuild b/dev-python/micawber/micawber-0.5.4.ebuild
index 87166df121a1..bcebcf389f48 100644
--- a/dev-python/micawber/micawber-0.5.4.ebuild
+++ b/dev-python/micawber/micawber-0.5.4.ebuild
@@ -19,7 +19,7 @@ RESTRICT="!test? ( test )"
BDEPEND="
test? (
$(python_gen_impl_dep sqlite)
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/django[${PYTHON_USEDEP}]
)"
diff --git a/dev-python/mkdocs-material-extensions/mkdocs-material-extensions-1.0.3.ebuild b/dev-python/mkdocs-material-extensions/mkdocs-material-extensions-1.0.3.ebuild
index 9e8a11b06fcb..a097bcd82d6c 100644
--- a/dev-python/mkdocs-material-extensions/mkdocs-material-extensions-1.0.3.ebuild
+++ b/dev-python/mkdocs-material-extensions/mkdocs-material-extensions-1.0.3.ebuild
@@ -25,7 +25,7 @@ PDEPEND=">=dev-python/mkdocs-material-5.0.0[${PYTHON_USEDEP}]"
# by first emerging with FEATURES="-test"
BDEPEND="
test? ( ${PDEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
)
"
diff --git a/dev-python/pandas/pandas-1.2.3-r1.ebuild b/dev-python/pandas/pandas-1.2.3-r1.ebuild
index c8f0fca921c0..7fb2e473bcc8 100644
--- a/dev-python/pandas/pandas-1.2.3-r1.ebuild
+++ b/dev-python/pandas/pandas-1.2.3-r1.ebuild
@@ -28,7 +28,7 @@ RECOMMENDED_DEPEND="
# TODO: add pandas-gbq to the tree
OPTIONAL_DEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/blosc[${PYTHON_USEDEP}]
|| (
dev-python/html5lib[${PYTHON_USEDEP}]
@@ -67,7 +67,7 @@ DEPEND="${COMMON_DEPEND}
doc? (
${VIRTUALX_DEPEND}
app-text/pandoc
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
@@ -88,7 +88,7 @@ DEPEND="${COMMON_DEPEND}
${VIRTUALX_DEPEND}
${RECOMMENDED_DEPEND}
${OPTIONAL_DEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/openpyxl[${PYTHON_USEDEP}]
@@ -176,7 +176,7 @@ python_install_all() {
pkg_postinst() {
optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
- optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
+ optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
diff --git a/dev-python/pandas/pandas-1.2.4.ebuild b/dev-python/pandas/pandas-1.2.4.ebuild
index 74f03a0471fa..949852951883 100644
--- a/dev-python/pandas/pandas-1.2.4.ebuild
+++ b/dev-python/pandas/pandas-1.2.4.ebuild
@@ -28,7 +28,7 @@ RECOMMENDED_DEPEND="
# TODO: add pandas-gbq to the tree
OPTIONAL_DEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/blosc[${PYTHON_USEDEP}]
|| (
dev-python/html5lib[${PYTHON_USEDEP}]
@@ -65,7 +65,7 @@ DEPEND="${COMMON_DEPEND}
doc? (
${VIRTUALX_DEPEND}
app-text/pandoc
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
@@ -86,7 +86,7 @@ DEPEND="${COMMON_DEPEND}
${VIRTUALX_DEPEND}
${RECOMMENDED_DEPEND}
${OPTIONAL_DEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/openpyxl[${PYTHON_USEDEP}]
@@ -174,7 +174,7 @@ python_install_all() {
pkg_postinst() {
optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
- optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
+ optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
diff --git a/dev-python/pandas/pandas-1.2.5.ebuild b/dev-python/pandas/pandas-1.2.5.ebuild
index a55755019ca6..4d06d4f70ec3 100644
--- a/dev-python/pandas/pandas-1.2.5.ebuild
+++ b/dev-python/pandas/pandas-1.2.5.ebuild
@@ -28,7 +28,7 @@ RECOMMENDED_DEPEND="
# TODO: add pandas-gbq to the tree
OPTIONAL_DEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/blosc[${PYTHON_USEDEP}]
|| (
dev-python/html5lib[${PYTHON_USEDEP}]
@@ -65,7 +65,7 @@ DEPEND="${COMMON_DEPEND}
doc? (
${VIRTUALX_DEPEND}
app-text/pandoc
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
@@ -86,7 +86,7 @@ DEPEND="${COMMON_DEPEND}
${VIRTUALX_DEPEND}
${RECOMMENDED_DEPEND}
${OPTIONAL_DEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/openpyxl[${PYTHON_USEDEP}]
@@ -172,7 +172,7 @@ python_install_all() {
pkg_postinst() {
optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
- optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
+ optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
diff --git a/dev-python/pandas/pandas-1.3.0.ebuild b/dev-python/pandas/pandas-1.3.0.ebuild
index cf0c8aa8a43d..1bcde176494c 100644
--- a/dev-python/pandas/pandas-1.3.0.ebuild
+++ b/dev-python/pandas/pandas-1.3.0.ebuild
@@ -29,7 +29,7 @@ RECOMMENDED_DEPEND="
# TODO: add pandas-gbq to the tree
OPTIONAL_DEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/blosc[${PYTHON_USEDEP}]
|| (
dev-python/html5lib[${PYTHON_USEDEP}]
@@ -66,7 +66,7 @@ DEPEND="${COMMON_DEPEND}
doc? (
${VIRTUALX_DEPEND}
app-text/pandoc
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
@@ -87,7 +87,7 @@ DEPEND="${COMMON_DEPEND}
${VIRTUALX_DEPEND}
${RECOMMENDED_DEPEND}
${OPTIONAL_DEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/openpyxl[${PYTHON_USEDEP}]
dev-python/pymysql[${PYTHON_USEDEP}]
@@ -178,7 +178,7 @@ python_install_all() {
pkg_postinst() {
optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
- optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
+ optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
diff --git a/dev-python/pandas/pandas-1.3.1.ebuild b/dev-python/pandas/pandas-1.3.1.ebuild
index 922da786c996..db5cf8cfe606 100644
--- a/dev-python/pandas/pandas-1.3.1.ebuild
+++ b/dev-python/pandas/pandas-1.3.1.ebuild
@@ -29,7 +29,7 @@ RECOMMENDED_DEPEND="
# TODO: add pandas-gbq to the tree
OPTIONAL_DEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/blosc[${PYTHON_USEDEP}]
|| (
dev-python/html5lib[${PYTHON_USEDEP}]
@@ -66,7 +66,7 @@ DEPEND="${COMMON_DEPEND}
doc? (
${VIRTUALX_DEPEND}
app-text/pandoc
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
@@ -87,7 +87,7 @@ DEPEND="${COMMON_DEPEND}
${VIRTUALX_DEPEND}
${RECOMMENDED_DEPEND}
${OPTIONAL_DEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/openpyxl[${PYTHON_USEDEP}]
dev-python/pymysql[${PYTHON_USEDEP}]
@@ -178,7 +178,7 @@ python_install_all() {
pkg_postinst() {
optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
- optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
+ optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
diff --git a/dev-python/pandas/pandas-1.3.2.ebuild b/dev-python/pandas/pandas-1.3.2.ebuild
index cfd8cfcdb32f..dd278f44e3eb 100644
--- a/dev-python/pandas/pandas-1.3.2.ebuild
+++ b/dev-python/pandas/pandas-1.3.2.ebuild
@@ -29,7 +29,7 @@ RECOMMENDED_DEPEND="
# TODO: add pandas-gbq to the tree
OPTIONAL_DEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/blosc[${PYTHON_USEDEP}]
|| (
dev-python/html5lib[${PYTHON_USEDEP}]
@@ -66,7 +66,7 @@ DEPEND="${COMMON_DEPEND}
doc? (
${VIRTUALX_DEPEND}
app-text/pandoc
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
@@ -87,7 +87,7 @@ DEPEND="${COMMON_DEPEND}
${VIRTUALX_DEPEND}
${RECOMMENDED_DEPEND}
${OPTIONAL_DEPEND}
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/openpyxl[${PYTHON_USEDEP}]
dev-python/pymysql[${PYTHON_USEDEP}]
@@ -178,7 +178,7 @@ python_install_all() {
pkg_postinst() {
optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
- optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
+ optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
diff --git a/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.6.3.ebuild b/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.6.3.ebuild
index c690200bee56..1bd76057e442 100644
--- a/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.6.3.ebuild
+++ b/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.6.3.ebuild
@@ -17,7 +17,7 @@ KEYWORDS="amd64 x86"
BDEPEND="
test? (
- dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/pytest-regressions[${PYTHON_USEDEP}]
)"
diff --git a/dev-python/pyquery/pyquery-1.4.3.ebuild b/dev-python/pyquery/pyquery-1.4.3.ebuild
index f16a0025dd74..b7a5304d20e9 100644
--- a/dev-python/pyquery/pyquery-1.4.3.ebuild
+++ b/dev-python/pyquery/pyquery-1.4.3.ebuild
@@ -21,7 +21,7 @@ RDEPEND="
>=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
DEPEND="
test? (
- dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/webtest[${PYTHON_USEDEP}]
)"
@@ -39,5 +39,5 @@ python_test() {
}
pkg_postinst() {
- optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
+ optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup4
}
diff --git a/dev-python/pyspelling/pyspelling-2.7.2.ebuild b/dev-python/pyspelling/pyspelling-2.7.2.ebuild
index c22deee77eeb..ad241ebe9e03 100644
--- a/dev-python/pyspelling/pyspelling-2.7.2.ebuild
+++ b/dev-python/pyspelling/pyspelling-2.7.2.ebuild
@@ -27,7 +27,7 @@ KEYWORDS="amd64 x86"
RDEPEND="
|| ( app-text/aspell app-text/hunspell )
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/markdown[${PYTHON_USEDEP}]
diff --git a/dev-python/pyspelling/pyspelling-2.7.3.ebuild b/dev-python/pyspelling/pyspelling-2.7.3.ebuild
index 73d0ffb19840..ecc4d5168913 100644
--- a/dev-python/pyspelling/pyspelling-2.7.3.ebuild
+++ b/dev-python/pyspelling/pyspelling-2.7.3.ebuild
@@ -25,7 +25,7 @@ KEYWORDS="~amd64 ~x86"
RDEPEND="
|| ( app-text/aspell app-text/hunspell )
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/markdown[${PYTHON_USEDEP}]
diff --git a/dev-python/setuptools_rust/setuptools_rust-0.12.1.ebuild b/dev-python/setuptools_rust/setuptools_rust-0.12.1.ebuild
index 3be9c6d55400..9b6a7a9b8cbc 100644
--- a/dev-python/setuptools_rust/setuptools_rust-0.12.1.ebuild
+++ b/dev-python/setuptools_rust/setuptools_rust-0.12.1.ebuild
@@ -115,7 +115,7 @@ BDEPEND="
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
)
"
diff --git a/dev-python/soupsieve/soupsieve-2.2.1.ebuild b/dev-python/soupsieve/soupsieve-2.2.1.ebuild
index a484c1b991b6..6faa3118027a 100644
--- a/dev-python/soupsieve/soupsieve-2.2.1.ebuild
+++ b/dev-python/soupsieve/soupsieve-2.2.1.ebuild
@@ -18,7 +18,7 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x
BDEPEND="
test? (
- dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
<dev-python/lxml-4.6.3-r1[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
)
diff --git a/dev-python/sphinx-tabs/sphinx-tabs-3.1.0.ebuild b/dev-python/sphinx-tabs/sphinx-tabs-3.1.0.ebuild
index fcc594af6c7a..eae215832298 100644
--- a/dev-python/sphinx-tabs/sphinx-tabs-3.1.0.ebuild
+++ b/dev-python/sphinx-tabs/sphinx-tabs-3.1.0.ebuild
@@ -22,7 +22,7 @@ RDEPEND="
BDEPEND="
test? (
- dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/pytest-regressions[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/sphinx-testing[${PYTHON_USEDEP}]
diff --git a/dev-python/webtest/webtest-2.0.35.ebuild b/dev-python/webtest/webtest-2.0.35.ebuild
index 9580a68bc44d..6b1ffd9087b4 100644
--- a/dev-python/webtest/webtest-2.0.35.ebuild
+++ b/dev-python/webtest/webtest-2.0.35.ebuild
@@ -26,7 +26,7 @@ RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
>=dev-python/webob-1.2[${PYTHON_USEDEP}]
>=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]"
BDEPEND="
app-arch/unzip
test? (
diff --git a/dev-python/webtest/webtest-3.0.0.ebuild b/dev-python/webtest/webtest-3.0.0.ebuild
index 8e044a55a55a..209ac9463c78 100644
--- a/dev-python/webtest/webtest-3.0.0.ebuild
+++ b/dev-python/webtest/webtest-3.0.0.ebuild
@@ -25,7 +25,7 @@ RDEPEND="
dev-python/pastedeploy[${PYTHON_USEDEP}]
>=dev-python/webob-1.2[${PYTHON_USEDEP}]
>=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]"
BDEPEND="
app-arch/unzip
test? (