summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyftpdlib/Manifest2
-rw-r--r--dev-python/pyftpdlib/files/pyftpdlib-1-pypy-test.patch20
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.0.1-r1.ebuild41
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.3.0.ebuild40
4 files changed, 0 insertions, 103 deletions
diff --git a/dev-python/pyftpdlib/Manifest b/dev-python/pyftpdlib/Manifest
index 0e400e2416ea..a058caa8f9d7 100644
--- a/dev-python/pyftpdlib/Manifest
+++ b/dev-python/pyftpdlib/Manifest
@@ -1,3 +1 @@
-DIST pyftpdlib-1.0.1.tar.gz 116428 SHA256 bec5c2af5942c3970d53b1a9fa27286eba40c2089e3e0ef653ff6f5ed0c4865b SHA512 478f04cb156a6178f03aee40190f17b65e42f04c60311936bf068d11f9ffbd8ae9a118fea456386ccf5184e3fed6270b40b4dfec6523902e310f78ec73785be8 WHIRLPOOL 71b34ef1031b402b2be0d7aac64f796820a20e022fc71fb451777cc4dc50b28ba48dca20608958cd670d90a9baf839c8e4933ddb63b0484fff425faaa5e5e3b1
-DIST pyftpdlib-1.3.0.tar.gz 120206 SHA256 5dec22e691bd75ee0097f2e623df6c7b81a7cc373118f1550a16079dbddc701f SHA512 eacd617aa136c2a9a8836d25c632f30fbc9ad14650d34e0a8f6562c1a5af8e2e3ae0592d7f5456b88818142d63a08c140e75ce2e0a73811c29a7dd5e08700b87 WHIRLPOOL e4ee34587e60f9a41b5332a62a5e4d4914822ffa1bd4cc700ebb03a31fdca50ffa15a55d6d5afb73177d20bbbb30123ca6756629eef936d6bbb8a5d959535d74
DIST pyftpdlib-1.4.0.tar.gz 116280 SHA256 5fdd1492efe478f4c354f7d65d9308359751c8fb1d0376466b74a76721c5fcf3 SHA512 61cf28d72a3a99bdc9bddcf434275e4edaeff60bf6481c1e854d81a4ea23ae97b73c8da9d0629a705a003ae8a941c529f9b9ed7cfa25759bd5cd6517f9958ff9 WHIRLPOOL 676f58061e07aa8a9dcce9c7076962875866cebca8eacdd624053cab32de3a7bdb0b17337105839b6c997bf2b4263e759c962362930afddaedc1e9a151b855fa
diff --git a/dev-python/pyftpdlib/files/pyftpdlib-1-pypy-test.patch b/dev-python/pyftpdlib/files/pyftpdlib-1-pypy-test.patch
deleted file mode 100644
index e1b30553fcbe..000000000000
--- a/dev-python/pyftpdlib/files/pyftpdlib-1-pypy-test.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -ur pyftpdlib-1.0.1.orig/test/test_ftpd.py pyftpdlib-1.0.1/test/test_ftpd.py
---- test/test_ftpd.py 2013-02-23 03:07:13.000000000 +0800
-+++ test/test_ftpd.py 2013-03-13 23:05:48.392965468 +0800
-@@ -33,7 +33,7 @@
- import threading
- import unittest
- import socket
--import os
-+import os, sys
- import shutil
- import time
- import re
-@@ -1358,6 +1358,7 @@
- self.assertEqual(getmode(), '0555')
-
-
-+@unittest.skipIf(hasattr(sys, 'pypy_version_info'), "temp. disabling of pypy")
- class TestFtpStoreData(TestCase):
- """Test STOR, STOU, APPE, REST, TYPE."""
- server_class = FTPd
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.0.1-r1.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.0.1-r1.ebuild
deleted file mode 100644
index 1ecfe3fcdbdc..000000000000
--- a/dev-python/pyftpdlib/pyftpdlib-1.0.1-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-PYTHON_REQ_USE="ssl(+)"
-# pypy has no spwd.so
-
-inherit distutils-r1
-
-DESCRIPTION="Python FTP server library"
-HOMEPAGE="https://code.google.com/p/pyftpdlib/ https://pypi.python.org/pypi/pyftpdlib"
-SRC_URI="https://pyftpdlib.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
-IUSE="examples ssl"
-
-DEPEND="ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
-
-DOCS="CREDITS HISTORY"
-
-#PATCHES=( "${FILESDIR}"/${PN}-1-pypy-test.patch )
-
-python_test() {
- cd "${BUILD_DIR}" || die
- for test in "${S}"/test/test_*.py; do
- "${PYTHON}" "${test}" || die "Testing failed with ${EPYTHON}"
- done
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r demo test
- fi
-}
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.3.0.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.3.0.ebuild
deleted file mode 100644
index bae34f1d4dbe..000000000000
--- a/dev-python/pyftpdlib/pyftpdlib-1.3.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} pypy )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python FTP server library"
-HOMEPAGE="https://code.google.com/p/pyftpdlib/ https://pypi.python.org/pypi/pyftpdlib"
-SRC_URI="https://pyftpdlib.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
-IUSE="examples ssl"
-
-DEPEND="ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
-
-# Usual; requ'd for a sane testsuite run
-DISTUTILS_NO_PARALLEL_BUILD=1
-
-python_prepare_all() {
- # https://code.google.com/p/pyftpdlib/issues/detail?id=292&thanks=292&ts=1400308829
- # Disable failing test
- sed -e 's:test_on_incomplete_file_received:_&:' -i test/test_ftpd.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" test/test_ftpd.py || die
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( demo/. )
- distutils-r1_python_install_all
-}