summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/whoosh/whoosh-2.7.4.ebuild')
-rw-r--r--dev-python/whoosh/whoosh-2.7.4.ebuild34
1 files changed, 17 insertions, 17 deletions
diff --git a/dev-python/whoosh/whoosh-2.7.4.ebuild b/dev-python/whoosh/whoosh-2.7.4.ebuild
index b89e1c69636d..b580f97f13ba 100644
--- a/dev-python/whoosh/whoosh-2.7.4.ebuild
+++ b/dev-python/whoosh/whoosh-2.7.4.ebuild
@@ -2,28 +2,31 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
-
-MY_PN="Whoosh"
+PYTHON_COMPAT=( python2_7 python{3_4,3_5} pypy )
inherit distutils-r1
DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
HOMEPAGE="https://bitbucket.org/mchaput/whoosh/wiki/Home/ https://pypi.python.org/pypi/Whoosh/"
-SRC_URI="mirror://pypi/W/${MY_PN}/${MY_PN}-${PV}.zip"
-
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+SRC_URI="mirror://pypi/W/${PN^}/${P^}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~x86"
IUSE="doc test"
-S="${WORKDIR}/${MY_PN}-${PV}"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${P^}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.7.4-tests-specify-utf8.patch
+)
python_prepare_all() {
# (backport from upstream)
@@ -37,7 +40,10 @@ python_prepare_all() {
python_compile_all() {
# https://bitbucket.org/mchaput/whoosh/issue/403/
- use doc && sphinx-build -b html -c docs/source/ docs/source/ docs/source/build/html
+ if use doc; then
+ sphinx-build -b html -c docs/source/ docs/source/ docs/source/build/html || die
+ HTML_DOCS=( docs/source/build/html/. )
+ fi
}
python_test() {
@@ -45,9 +51,3 @@ python_test() {
# tarball missing a file english-words.10.gz which when added sees all tests pass.
esetup.py test
}
-
-python_install_all() {
- local DOCS=( README.txt )
- use doc && local HTML_DOCS=( docs/source/build/html/. )
- distutils-r1_python_install_all
-}