summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/reportlab')
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-3.4.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index 2ce9d324fac6..5cd0844fdfc7 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -1,2 +1,3 @@
DIST pfbfer-20070710.zip 677333 SHA256 fb1462ff6ce8efae58a0c496f0537c5ac16d4895c68f1640c2973db574ddb376 SHA512 6fd4a5d955464b10d13a7b748703450c1fe120d5ed09e8cfa1b4dfa9c183c59fe001df29433af551796b0df62544b7ddc364f9bb1bdcc2cd300434340ffcc4f2 WHIRLPOOL 5aad616d063cab1862d77fbbf9f625f20c4bcbf09e45688719e312c1e8d3815f1b295d290b78f6c4789919cef39856ec223c30a2e424eeb1c8137cccc5ceb90f
DIST reportlab-3.3.0.tar.gz 1959255 SHA256 f48900b9321bcb2871a46543993bd995148d769a11a9e24495f25b4ec0bbe267 SHA512 a6dbe5db13a9e430855ba8139310d8f04ade221c340467c2e0f5bf60c700f17148069358beb057f1667217a09b71ba1ae3112bd02e7c8de00e53a8f852acb8df WHIRLPOOL a62cb9ecd2f85324e8e847365346e4fbd64ef098032a54884149db43f4a9f42a0358747a185f1d87107472689bd08f86f70f976da49d09806fc4acf1b175f4f2
+DIST reportlab-3.4.0.tar.gz 1995779 SHA256 5beaf35e59dfd5ebd814fdefd76908292e818c982bd7332b5d347dfd2f01c343 SHA512 7f00074b93be49e1aa7650e61381e285598599911b12a6b63c0f12d6eb64bc59afb6907b683350740b0a81c99a3164373b27e18cfccc0f9da12405c3dacd1ff7 WHIRLPOOL 7d97433ce15d4730b6b062ae67603e81aa210483f01dcb0b972f048aeac1ef4fff233f6c6b4943e98667a0205d3e8670c21e0f5fa1bd171ec37681d6f2a8b1c2
diff --git a/dev-python/reportlab/reportlab-3.4.0.ebuild b/dev-python/reportlab/reportlab-3.4.0.ebuild
new file mode 100644
index 000000000000..ffc0d13ba0a2
--- /dev/null
+++ b/dev-python/reportlab/reportlab-3.4.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} ) # Tests crash with pypy
+
+inherit distutils-r1 flag-o-matic prefix
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="http://www.reportlab.com/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
+ http://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/pillow-2.4.0[tiff,truetype,jpeg,${PYTHON_USEDEP}]
+ media-libs/libart_lgpl
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-2.2[${PYTHON_USEDEP}]
+ app-arch/unzip
+"
+
+PATCHES=(
+ "${FILESDIR}"/reportlab-no-pip.patch
+)
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+python_prepare_all() {
+ sed -i \
+ -e 's|/usr/local/Acrobat|/opt/Acrobat|g' \
+ -e 's|%(HOME)s/fonts|%(HOME)s/.fonts|g' \
+ src/reportlab/rl_config.py || die
+
+ eprefixify setup.py
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ pushd tests > /dev/null || die
+ "${PYTHON}" runAll.py || die "Testing failed with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ if use examples ; then
+ docinto examples
+ dosod -r demos/. tools/pythonpoint/demos
+ fi
+
+ distutils-r1_python_install_all
+}