summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-cluster/python-cluster-1.2.2.ebuild')
-rw-r--r--dev-python/python-cluster/python-cluster-1.2.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-cluster/python-cluster-1.2.2.ebuild b/dev-python/python-cluster/python-cluster-1.2.2.ebuild
new file mode 100644
index 000000000000..92f38fc5faa9
--- /dev/null
+++ b/dev-python/python-cluster/python-cluster-1.2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Allows grouping a list of arbitrary objects into related groups (clusters)"
+HOMEPAGE="https://github.com/exhuma/python-cluster"
+SRC_URI="mirror://pypi/c/cluster/cluster-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${WORKDIR}/cluster-${PV}"
+
+python_test() {
+ "${PYTHON}" test.py || die "Testing failed with ${EPYTHON}"
+}