summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-describe/pytest-describe-1.0.0.ebuild')
-rw-r--r--dev-python/pytest-describe/pytest-describe-1.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-describe/pytest-describe-1.0.0.ebuild b/dev-python/pytest-describe/pytest-describe-1.0.0.ebuild
new file mode 100644
index 000000000000..30f9e69afae6
--- /dev/null
+++ b/dev-python/pytest-describe/pytest-describe-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Describe-style plugin for pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-describe
+ https://pypi.org/project/pytest-describe"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ # We need to disable some plugins because tests don't like unexpected
+ # output
+ PYTEST_ADDOPTS="-p no:flaky -p no:capturelog" pytest -vv ||
+ die "Tests failed under ${EPYTHON}"
+}