summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/pyparted-3.10.7.ebuild7
-rw-r--r--dev-python/pyparted/pyparted-3.11.2.ebuild7
-rw-r--r--dev-python/pyparted/pyparted-3.11.3.ebuild2
-rw-r--r--dev-python/pyparted/pyparted-999999.ebuild2
4 files changed, 6 insertions, 12 deletions
diff --git a/dev-python/pyparted/pyparted-3.10.7.ebuild b/dev-python/pyparted/pyparted-3.10.7.ebuild
index 307aca112dce..9d7910371fc0 100644
--- a/dev-python/pyparted/pyparted-3.10.7.ebuild
+++ b/dev-python/pyparted/pyparted-3.10.7.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
DESCRIPTION="Python bindings for sys-block/parted"
@@ -14,10 +14,7 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 hppa ia64 ppc ppc64 sparc x86"
IUSE="test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="
- test? ( python_targets_python2_7 )
-"
+RESTRICT="test"
RDEPEND="
>=sys-block/parted-3.1
diff --git a/dev-python/pyparted/pyparted-3.11.2.ebuild b/dev-python/pyparted/pyparted-3.11.2.ebuild
index 5a9a66752a3f..d3ac7bb90e10 100644
--- a/dev-python/pyparted/pyparted-3.11.2.ebuild
+++ b/dev-python/pyparted/pyparted-3.11.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
DESCRIPTION="Python bindings for sys-block/parted"
@@ -13,10 +13,7 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="
- test? ( python_targets_python2_7 )
-"
+RESTRICT="test"
RDEPEND="
>=sys-block/parted-3.1
diff --git a/dev-python/pyparted/pyparted-3.11.3.ebuild b/dev-python/pyparted/pyparted-3.11.3.ebuild
index a058461368ad..9412f7f7545e 100644
--- a/dev-python/pyparted/pyparted-3.11.3.ebuild
+++ b/dev-python/pyparted/pyparted-3.11.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1 flag-o-matic
DESCRIPTION="Python bindings for sys-block/parted"
diff --git a/dev-python/pyparted/pyparted-999999.ebuild b/dev-python/pyparted/pyparted-999999.ebuild
index b34350ec1632..9a99955ada23 100644
--- a/dev-python/pyparted/pyparted-999999.ebuild
+++ b/dev-python/pyparted/pyparted-999999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1 flag-o-matic git-r3
DESCRIPTION="Python bindings for sys-block/parted"