summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygcrypt/pygcrypt-1.0.0.ebuild')
-rw-r--r--dev-python/pygcrypt/pygcrypt-1.0.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pygcrypt/pygcrypt-1.0.0.ebuild b/dev-python/pygcrypt/pygcrypt-1.0.0.ebuild
new file mode 100644
index 000000000000..1dfdb7d44672
--- /dev/null
+++ b/dev-python/pygcrypt/pygcrypt-1.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="CFFI interface to dev-libs/libgcrypt"
+HOMEPAGE="https://framagit.org/okhin/pygcrypt/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-libs/libgcrypt:0=
+ virtual/python-cffi[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die "Tests failed against ${EPYTHON}"
+}