summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyev')
-rw-r--r--dev-python/pyev/Manifest2
-rw-r--r--dev-python/pyev/metadata.xml17
-rw-r--r--dev-python/pyev/pyev-0.8.1.ebuild35
-rw-r--r--dev-python/pyev/pyev-0.9.0.ebuild26
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/pyev/Manifest b/dev-python/pyev/Manifest
new file mode 100644
index 000000000000..5f9d1f5dd185
--- /dev/null
+++ b/dev-python/pyev/Manifest
@@ -0,0 +1,2 @@
+DIST pyev-0.8.1-4.04.tar.gz 623423 SHA256 5e634953c08d27141f7e64c0c85fb64ea9756545309073ea8cd5b0a7050950e5 SHA512 59fd8564445822c12032889c826ad148b15544462aa72d4658cc5887b5af3542e399d2d47767f935f8638836f9ba954e4c8ceef6f5f630e3ee035ba96d339e1d WHIRLPOOL a66bca355e6ff05730fd9ba51c66d6dd7bd343fa5ddfe83fb5f6a3cd1bf1216d8916249cc9f0310f2db37ad44a3bbc66547fa59fc5aca88e401f9f10f64be443
+DIST pyev-0.9.0.tar.gz 223943 SHA256 5d030a993cb0e9a74034e57b2e1e3f6378f25083bb886583badf68c0e800c665 SHA512 05eafd70b843be8ee84a9a384fea9f222445930de00c5a6ac38c6e798f22165914fab3825be8e98e84fa68fdfe9e477718190a6939737667868b4badeb1eafa8 WHIRLPOOL d89da560e0ab96996ec05b629ec5eb9f8c9efcbb147411658fad89e9a77aaa3e70a6c8b20bd0b2ad99619a363e0335a154de2fe1a519184cdc4e02343a077687
diff --git a/dev-python/pyev/metadata.xml b/dev-python/pyev/metadata.xml
new file mode 100644
index 000000000000..8f4c7f40ad14
--- /dev/null
+++ b/dev-python/pyev/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <longdescription lang="en">
+ Pyev is the python interface of <pkg>dev-libs/libev</pkg>
+ which provides event loop, support select, poll, the
+ Linux-specific epoll, and so on.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pyev</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyev/pyev-0.8.1.ebuild b/dev-python/pyev/pyev-0.8.1.ebuild
new file mode 100644
index 000000000000..2544879d4421
--- /dev/null
+++ b/dev-python/pyev/pyev-0.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_P=${P}-4.04
+
+DESCRIPTION="Python libev interface, an event loop"
+HOMEPAGE="http://code.google.com/p/pyev/
+ http://pythonhosted.org/pyev/"
+SRC_URI="mirror://pypi/p/pyev/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE=""
+
+RDEPEND="dev-libs/libev
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+HTML_DOCS=( doc/. )
+
+python_prepare() {
+ distutils-r1_python_prepare
+}
diff --git a/dev-python/pyev/pyev-0.9.0.ebuild b/dev-python/pyev/pyev-0.9.0.ebuild
new file mode 100644
index 000000000000..76f012323c82
--- /dev/null
+++ b/dev-python/pyev/pyev-0.9.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python libev interface, an event loop"
+HOMEPAGE="http://code.google.com/p/pyev/
+ http://pythonhosted.org/pyev/"
+SRC_URI="mirror://pypi/p/pyev/${P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libev"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+HTML_DOCS=( doc/. )