summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-1.1.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 163886eb44dd..b8d15153f5c0 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,3 +1,4 @@
DIST Nuitka-1.0.8.tar.gz 3890590 BLAKE2B 04257834d79f0988800a06d9b4725e9fa694bf7f9aafebbfb9ddbb09a2a5f666c02f13bf8ee56fd3360216faa31cd7b14a30d9a2daf23eef719ed568bfd3501c SHA512 824830121ca87b33aebcee074e0af52e456942190168186248a9ed62937bb044c6741ff721bd4bcd7d657cae96d573c1a6b9cb1fde6374073c12c1e1f6a6df26
DIST Nuitka-1.1.1.tar.gz 3921434 BLAKE2B 75198a2012f56db86a324bb73dd3a181aabbfb4e251e3727ee4fede4011a2cef48e68e6d075d99bae18e76602ab02b021584538c8d0396edd4b8bcc1c5a8eb59 SHA512 aa9bb9786b81475ec953cb72aa4efd27a9d9d7de1e2464c5b328c58dcc9667175634fdbeefb2eb7e50abd767f5d5def37ad24fa77c767c37820684bfc41cea1e
+DIST Nuitka-1.1.2.tar.gz 3921859 BLAKE2B d9d2c41a385ef0c9204b92fac9f5784b6ba2bdaffa4d04cc085a774f5f7cede95132ac985b4862a40c7977e3ec7128082800f17391b720ff3abb666f33d7089a SHA512 848a2a990585c50cc74d35288c12e87af452a05a697008fab3161ebfc545a4d0ca0cfedd3c5c4815755d76d366efb5634d2a92d62da1dfb6b458f96782eb04b5
DIST Nuitka-1.1.tar.gz 3920532 BLAKE2B 0d6ff01815bbc9216b5e5157bcb849b5182d025fe16523efde2bd812ca90d0b8008ba0d55e20e40b41c81250c2a1d309f99adff6498a3466f4d546ce8a7dfbca SHA512 abf9a2f07751f963bb727bc6c1affca0be3f02e6d1ead0206979b00589de0571a8e8e4e6af08bbc8fa285b1e2cbc5971bb88b417aca73c8069da200f7cd04fe5
diff --git a/dev-python/nuitka/nuitka-1.1.2.ebuild b/dev-python/nuitka/nuitka-1.1.2.ebuild
new file mode 100644
index 000000000000..b55f0385d58a
--- /dev/null
+++ b/dev-python/nuitka/nuitka-1.1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}