summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.7-pipdated.patch')
-rw-r--r--dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.7-pipdated.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.7-pipdated.patch b/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.7-pipdated.patch
new file mode 100644
index 000000000000..3400ec9f0e79
--- /dev/null
+++ b/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.7-pipdated.patch
@@ -0,0 +1,24 @@
+Remove version checks using pipdated.
+
+Patch by Marius Brehler <marbre@linux.sungazer.de>
+--- a/matplotlib2tikz/__init__.py
++++ b/matplotlib2tikz/__init__.py
+@@ -15,7 +15,3 @@ from matplotlib2tikz.__about__ import (
+ )
+
+ from matplotlib2tikz.save import get_tikz_code, save
+-
+-import pipdated
+-if pipdated.needs_checking(__name__):
+- print(pipdated.check(__name__, __version__))
+
+--- a/setup.py
++++ b/setup.py
+@@ -34,7 +34,6 @@ setup(
+ 'matplotlib >=1.4.0',
+ 'numpy',
+ 'Pillow >= 3.0.0',
+- 'pipdated',
+ ],
+ description='convert matplotlib figures into TikZ/PGFPlots',
+ long_description=read('README.rst'),