summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libtmux')
-rw-r--r--dev-python/libtmux/Manifest1
-rw-r--r--dev-python/libtmux/libtmux-0.9.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/libtmux/Manifest b/dev-python/libtmux/Manifest
index 2b790760cbc6..472a33f70a1b 100644
--- a/dev-python/libtmux/Manifest
+++ b/dev-python/libtmux/Manifest
@@ -1 +1,2 @@
DIST libtmux-v0.8.5.tar.gz 222445 BLAKE2B 5af148555eb89c66bdc66f3f214967f7e901d9b86ea85e02a9fba64f2eb3559828519ba8120eaee5eb86ec75bee2e599a08384dd096de8dc0969129c58172c1e SHA512 d456725c3ca41a672ee5239bfb5f42a262674638d308fa141627995be8b8fe348bb8713b735eb05c5a3cc73f35fe3f6fac12024f6254c950a3048b2e07606363
+DIST libtmux-v0.9.0.tar.gz 215649 BLAKE2B fdf6f424ce8eead5f0f19cb53bfd438e9cd7b5326e57e676281f74cedac6e1bcd7cded27e4ef226d2fc3bc09bbb57ff0e63aaa7d901ab910b6a890275c7fe63d SHA512 d47078300614b2a286eab6063c9492baa115787b917d2fb2e4188032ce580f495f0e7f4a14383407c61063a77d640092d117ba43974524f18da024dfc687c8a5
diff --git a/dev-python/libtmux/libtmux-0.9.0.ebuild b/dev-python/libtmux/libtmux-0.9.0.ebuild
new file mode 100644
index 000000000000..b252f9c9bdae
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="python api for tmux"
+HOMEPAGE="https://libtmux.git-pull.com/"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND=">=app-misc/tmux-3.0a"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python3_{7..9})
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+ rm requirements/doc.txt || die
+
+ distutils-r1_python_prepare_all
+}