summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/git-python/git-python-2.0.5.ebuild')
-rw-r--r--dev-python/git-python/git-python-2.0.5.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/git-python/git-python-2.0.5.ebuild b/dev-python/git-python/git-python-2.0.5.ebuild
deleted file mode 100644
index 68182b77ea49..000000000000
--- a/dev-python/git-python/git-python-2.0.5.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_PN="GitPython"
-MY_PV="${PV/_rc/.RC}"
-MY_P="${MY_PN}-${MY_PV}"
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="http://gitorious.org/git-python https://pypi.python.org/pypi/GitPython"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# Tests dont make sense without a git repo
-RESTRICT="test"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-0.6.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-# $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
-# is the correct entry for mock, however while RESTRICT="test"
-# there is little point in setting it since it is inactive
-S="${WORKDIR}/${MY_P}"