summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/discogs-client/discogs-client-2.0.2.ebuild')
-rw-r--r--dev-python/discogs-client/discogs-client-2.0.2.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/discogs-client/discogs-client-2.0.2.ebuild b/dev-python/discogs-client/discogs-client-2.0.2.ebuild
deleted file mode 100644
index dfb505c5d9d8..000000000000
--- a/dev-python/discogs-client/discogs-client-2.0.2.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-# Not py3 capable due to oauth2 supports py2 pypy only
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Official Python API client for Discogs"
-HOMEPAGE="https://github.com/discogs/discogs_client https://pypi.org/project/discogs-client/"
-#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-SRC_URI="https://github.com/discogs/${PN/-/_}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
- dev-python/oauth2[${PYTHON_USEDEP}]"
-# It's either this or make a test use flag to add RDEPEND behind it. Both work
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}"/${P/-/_}
-
-python_test() {
- "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
-}