summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-redis/pecl-redis-2.2.7-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/pecl-redis-2.2.7-r1.ebuild b/dev-php/pecl-redis/pecl-redis-2.2.7-r1.ebuild
new file mode 100644
index 000000000000..276b547335b9
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-2.2.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="redis"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-4 php5-5 php5-6"
+
+DOCS="arrays.markdown README.markdown"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="PHP extension for interfacing with Redis"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="igbinary"
+
+DEPEND="igbinary? (
+ php_targets_php5-4? ( dev-php/igbinary[php_targets_php5-4] )
+ php_targets_php5-5? ( dev-php/igbinary[php_targets_php5-5] )
+ php_targets_php5-6? ( dev-php/igbinary[php_targets_php5-6] ) )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ my_conf="--enable-redis
+ $(use_enable igbinary redis-igbinary)"
+
+ php-ext-source-r2_src_configure
+}