summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Net_DNSBL/PEAR-Net_DNSBL-1.3.7-r1.ebuild')
-rw-r--r--dev-php/PEAR-Net_DNSBL/PEAR-Net_DNSBL-1.3.7-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/PEAR-Net_DNSBL/PEAR-Net_DNSBL-1.3.7-r1.ebuild b/dev-php/PEAR-Net_DNSBL/PEAR-Net_DNSBL-1.3.7-r1.ebuild
new file mode 100644
index 000000000000..cd4446fd2f05
--- /dev/null
+++ b/dev-php/PEAR-Net_DNSBL/PEAR-Net_DNSBL-1.3.7-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PHP library to query DNS blacklists"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~sparc ~x86"
+IUSE="examples"
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-Cache_Lite
+ dev-php/PEAR-HTTP_Request2
+ dev-php/PEAR-Net_DNS
+ dev-php/PEAR-PEAR
+ examples? ( dev-lang/php:*[cli] dev-php/PEAR-Console_Getopt )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ use examples && dodoc -r examples
+
+ insinto /usr/share/php
+ doins -r Net
+}