summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild')
-rw-r--r--dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild b/dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild
new file mode 100644
index 000000000000..eaadf2ff7ca4
--- /dev/null
+++ b/dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DEXTER
+MODULE_VERSION=0.25
+inherit perl-module
+
+DESCRIPTION="Error handling with exception class"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( >=dev-perl/Test-Unit-Lite-0.120.0 )
+"
+
+SRC_TEST="do parallel"
+
+PATCHES=(
+ "${FILESDIR}/${P}-sprintf.patch"
+)
+
+src_install(){
+ perl-module_src_install
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/
+ doins -r examples/
+}