summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/seq/seq-1.ebuild')
-rw-r--r--dev-ml/seq/seq-1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/seq/seq-1.ebuild b/dev-ml/seq/seq-1.ebuild
new file mode 100644
index 000000000000..d76fea7d78bd
--- /dev/null
+++ b/dev-ml/seq/seq-1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Compatibility package for OCaml's standard iterator type starting from 4.07."
+HOMEPAGE="https://github.com/ocaml/opam-repository/blob/master/packages/seq/seq.base/opam"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+"
+BDEPEND=""
+S="${WORKDIR}"
+
+src_prepare() {
+ cp "${FILESDIR}/"{seq.install,META.seq} "${S}/" || die
+ default
+}