summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/pipebang')
-rw-r--r--dev-ml/pipebang/Manifest3
-rw-r--r--dev-ml/pipebang/metadata.xml8
-rw-r--r--dev-ml/pipebang/pipebang-109.28.00.ebuild20
-rw-r--r--dev-ml/pipebang/pipebang-109.60.00.ebuild20
-rw-r--r--dev-ml/pipebang/pipebang-110.01.00.ebuild21
5 files changed, 72 insertions, 0 deletions
diff --git a/dev-ml/pipebang/Manifest b/dev-ml/pipebang/Manifest
new file mode 100644
index 000000000000..fa94c00b98fe
--- /dev/null
+++ b/dev-ml/pipebang/Manifest
@@ -0,0 +1,3 @@
+DIST pipebang-109.28.00.tar.gz 43937 SHA256 590475b17b44b268f5d5318a3348f1fd8d1aed48f4d1ac7633ed162b5f277137 SHA512 99a0d2aae20265e9512199775e756863e66e1c5481cab75ba66969974a0ddd18207204098616473f0c8cc088ef2f05e66aea3e2fd75b413fcd4e56ded04228fe WHIRLPOOL 24aba6d3e50990e0640e9adc7d8dc0adddd461454a0227408d818c5fd46dd268a131aa264de5832e9d062cf0c155076ffb434a941345fa5eb85fb19e2497199c
+DIST pipebang-109.60.00.tar.gz 47044 SHA256 cb68e0e03aa01c523ebe3f458126abbe59e0698d3855ed779e33b1654179ea50 SHA512 ca37241e0fad5668ddaa93ead89bd83e6c674e3773001dada1bafdd9eecbcb86b9992c3860ae0b2a0b99e472c931f90c46319f010aeeb1babd916ef1a5438ab3 WHIRLPOOL 1a35232a4de31cb6470bf1ee8756b4ce2206bbff93b3d512beedbb2ae46754593762edac4fec39ff6416b03429cc28abe71399ad4694ee3b20a568214daab470
+DIST pipebang-110.01.00.tar.gz 47043 SHA256 a8858d9607c15cdf0a775196be060c8d91de724fc80a347d7a76ef1d38329096 SHA512 3720aef1e4214a9aed855ae23833c9f97b62ae090478713553d97a78b6ec5ed04a361b3ae83fc8db434255da0242fe09db3d8c6690cc1ac6e7f359fb259e226d WHIRLPOOL 8411fa3e25111d8f2d444c847b092cd47e3af2d9b81f68a819a3dad125c412e9e767208bfd6303e6007616178d2ebddc2a5a5a5d185fbf70bb6698f9d850eb7b
diff --git a/dev-ml/pipebang/metadata.xml b/dev-ml/pipebang/metadata.xml
new file mode 100644
index 000000000000..abf9563dd5c5
--- /dev/null
+++ b/dev-ml/pipebang/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="bitbucket">yminsky/ocaml-core</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/pipebang/pipebang-109.28.00.ebuild b/dev-ml/pipebang/pipebang-109.28.00.ebuild
new file mode 100644
index 000000000000..22d59d46e53f
--- /dev/null
+++ b/dev-ml/pipebang/pipebang-109.28.00.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Syntax extension to transform x |! f into f x"
+HOMEPAGE="http://bitbucket.org/yminsky/ocaml-core/wiki/Home"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-ml/type-conv-${PV}:="
+RDEPEND="${DEPEND}"
diff --git a/dev-ml/pipebang/pipebang-109.60.00.ebuild b/dev-ml/pipebang/pipebang-109.60.00.ebuild
new file mode 100644
index 000000000000..85e334be9992
--- /dev/null
+++ b/dev-ml/pipebang/pipebang-109.60.00.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Syntax extension to transform x |! f into f x"
+HOMEPAGE="http://bitbucket.org/yminsky/ocaml-core/wiki/Home"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-ml/type-conv-${PV}:="
+RDEPEND="${DEPEND}"
diff --git a/dev-ml/pipebang/pipebang-110.01.00.ebuild b/dev-ml/pipebang/pipebang-110.01.00.ebuild
new file mode 100644
index 000000000000..1d8e00bda23c
--- /dev/null
+++ b/dev-ml/pipebang/pipebang-110.01.00.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Syntax extension to transform x |! f into f x"
+HOMEPAGE="http://bitbucket.org/yminsky/ocaml-core/wiki/Home"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-ml/type-conv-109.60:=
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"