summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocplib-endian/ocplib-endian-1.1.ebuild')
-rw-r--r--dev-ml/ocplib-endian/ocplib-endian-1.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/ocplib-endian/ocplib-endian-1.1.ebuild b/dev-ml/ocplib-endian/ocplib-endian-1.1.ebuild
new file mode 100644
index 000000000000..92a15b5de084
--- /dev/null
+++ b/dev-ml/ocplib-endian/ocplib-endian-1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Functions to read and write int16/32/64 from strings, bytes, and bigarrays"
+HOMEPAGE="https://github.com/OCamlPro/ocplib-endian"
+SRC_URI="https://github.com/OCamlPro/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+ocamlopt"
+
+# 2 of 70 tests fail
+RESTRICT=test
+
+DEPEND="
+ >=dev-ml/cppo-1.1.0
+"
+RDEPEND=""