summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camldbm/camldbm-1.2.ebuild')
-rw-r--r--dev-ml/camldbm/camldbm-1.2.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-ml/camldbm/camldbm-1.2.ebuild b/dev-ml/camldbm/camldbm-1.2.ebuild
index 4bae2351d3f3..4b6ad3aee3d6 100644
--- a/dev-ml/camldbm/camldbm-1.2.ebuild
+++ b/dev-ml/camldbm/camldbm-1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,6 +16,11 @@ DEPEND=">=sys-libs/gdbm-1.9.1-r2[berkdb]
>=dev-lang/ocaml-3.12:=[ocamlopt]"
RDEPEND="${DEPEND}"
+QA_FLAGS_IGNORED=(
+ /usr/'lib.*'/ocaml/dbm.cmxs
+ /usr/'lib.*'/ocaml/stublibs/dllcamldbm.so
+)
+
src_install() {
dodir "$(ocamlc -where)/stublibs" # required and makefile does not create it
emake LIBDIR="${D}/$(ocamlc -where)" install