summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/radlib/radlib-2.12.0-r1.ebuild')
-rw-r--r--dev-libs/radlib/radlib-2.12.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/radlib/radlib-2.12.0-r1.ebuild b/dev-libs/radlib/radlib-2.12.0-r1.ebuild
new file mode 100644
index 000000000000..d5f7a87a83bc
--- /dev/null
+++ b/dev-libs/radlib/radlib-2.12.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils autotools
+
+DESCRIPTION="Rapid Application Development Library"
+HOMEPAGE="http://www.radlib.teel.ws/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD-2"
+
+SLOT="0"
+IUSE="mysql postgres sqlite static-libs"
+
+RDEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}"
+
+RESTRICT_USE="^^ ( mysql postgres )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable mysql)
+ $(use_enable postgres pgresql)
+ $(use_enable sqlite)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_test() { :; }