summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libntru/libntru-0.2.ebuild')
-rw-r--r--dev-libs/libntru/libntru-0.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libntru/libntru-0.2.ebuild b/dev-libs/libntru/libntru-0.2.ebuild
new file mode 100644
index 000000000000..0fd96e42da7d
--- /dev/null
+++ b/dev-libs/libntru/libntru-0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs multilib multilib-minimal
+
+DESCRIPTION="C Implementation of NTRUEncrypt"
+HOMEPAGE="https://github.com/tbuktu/libntru"
+SRC_URI="https://github.com/tbuktu/libntru/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/01-${P}-fix-build-on-macosx.patch \
+ "${FILESDIR}"/02-${P}-add-warnings.patch \
+ "${FILESDIR}"/03-${P}-install-rules.patch \
+ "${FILESDIR}"/04-${P}-respect-flags.patch \
+ "${FILESDIR}"/05-${P}-fix-memory-leak.patch
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+multilib_src_install() {
+ emake \
+ DESTDIR="${ED}" \
+ INST_LIBDIR="/usr/$(get_libdir)" \
+ INST_DOCDIR="/usr/share/doc/${PF}" \
+ install
+}