summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/distorm64/distorm64-3.1.ebuild')
-rw-r--r--dev-libs/distorm64/distorm64-3.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/distorm64/distorm64-3.1.ebuild b/dev-libs/distorm64/distorm64-3.1.ebuild
new file mode 100644
index 000000000000..3c89fcfb6e8c
--- /dev/null
+++ b/dev-libs/distorm64/distorm64-3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.5"
+
+inherit eutils distutils python
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+
+# This is not nice - hardcoding is bad
+SRC_URI="http://distorm.googlecode.com/files/distorm3-1.0.zip"
+S="${WORKDIR}/distorm3-1.0"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+pkg_setup() {
+ python_pkg_setup
+}
+
+src_compile() {
+ distutils_src_compile
+}