summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/haxe/Manifest1
-rw-r--r--dev-lang/haxe/haxe-4.3.1.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-lang/haxe/Manifest b/dev-lang/haxe/Manifest
index 9c7a5ad97aef..2d54822a0901 100644
--- a/dev-lang/haxe/Manifest
+++ b/dev-lang/haxe/Manifest
@@ -1,2 +1 @@
-DIST haxe-4.3.1.tar.gz 8398956 BLAKE2B f665f44120fb16b0f542e63c3ca00d84e90356e9dddbf3c50332bdee3770fa83a11d273db26c392799d39f8c035f5732bf4f7092a31750f5a5766588ee8a7849 SHA512 10961e4a5d7fad6789ea4465c96149c0becfe87ad447a0d808af5771ccbd2846b2e6715cbd72dcae9d4340ee45f7caac9238df94e3c079696e89f5551e8e1cdb
DIST haxe-4.3.3.tar.gz 8405617 BLAKE2B 0c27eafd6af0615b47de8a7bdbff25fe15d8bbf80525ede273a4a430cedde6f0d6c9871ae581e2a7e8a87b56862f0c1b9f6f862a7cbfb68ac943ccbc3ae36878 SHA512 fea25ae2ba7433e2f39faae8e05538419e5dfbc519315c8e91b84a2d0a7c9e2ed380b92b21c23ff597797311cbb7a15276b5f4623fb65c6e3d4d8cc801a74e23
diff --git a/dev-lang/haxe/haxe-4.3.1.ebuild b/dev-lang/haxe/haxe-4.3.1.ebuild
deleted file mode 100644
index 898185d66029..000000000000
--- a/dev-lang/haxe/haxe-4.3.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Multi-target universal programming language"
-HOMEPAGE="https://haxe.org/
- https://github.com/HaxeFoundation/haxe/"
-
-if [[ ${PV} == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/HaxeFoundation/haxe.git"
-else
- # Haxe-debian already contains correct git modules
- SRC_URI="https://github.com/HaxeFoundation/haxe-debian/archive/upstream/${PV}.tar.gz
- -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}"/haxe-debian-upstream-${PV}
-fi
-
-LICENSE="GPL-2+ MIT"
-SLOT="0/${PV}"
-IUSE="+ocamlopt"
-RESTRICT="strip"
-
-RDEPEND="
- >=dev-lang/ocaml-4:=[ocamlopt?]
- >=dev-ml/luv-0.5.12:=
- dev-ml/extlib:=
- dev-ml/ocaml-sha:=
- dev-ml/ptmap:=
- dev-ml/sedlex:=
- dev-ml/xml-light:=
-
- dev-lang/neko:=
- dev-libs/boehm-gc:=
- dev-libs/libpcre:=
- net-libs/mbedtls:=
- sys-libs/zlib:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-ml/camlp5
- dev-ml/dune
- dev-ml/findlib
-"
-
-QA_FLAGS_IGNORED="usr/bin/haxelib"
-QA_PRESTRIPPED="usr/bin/haxelib"
-
-src_configure() {
- export OCAMLOPT=$(usex ocamlopt ocamlopt.opt ocamlopt)
-}
-
-src_compile() {
- emake -j1 BRANCH="" COMMIT_DATE="" COMMIT_SHA="" \
- OCAMLOPT="${OCAMLOPT}" INSTALL_DIR=/usr
-}
-
-src_install() {
- emake DESTDIR="${D}" INSTALL_DIR=/usr install
- dodoc *.md
-}