summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/php-8.2.13-r1.ebuild4
-rw-r--r--dev-lang/php/php-8.3.0-r1.ebuild2
-rw-r--r--dev-lang/python/metadata.xml2
-rw-r--r--dev-lang/python/python-2.7.18_p16-r1.ebuild4
-rw-r--r--dev-lang/python/python-3.10.13.ebuild2
-rw-r--r--dev-lang/python/python-3.11.7.ebuild2
-rw-r--r--dev-lang/python/python-3.12.1.ebuild4
-rw-r--r--dev-lang/python/python-3.12.1_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.13.0_alpha2.ebuild2
-rw-r--r--dev-lang/python/python-3.8.18.ebuild2
-rw-r--r--dev-lang/python/python-3.9.18.ebuild2
-rw-r--r--dev-lang/ruby/ruby-3.1.4-r3.ebuild4
-rw-r--r--dev-lang/ruby/ruby-3.1.4-r4.ebuild4
-rw-r--r--dev-lang/ruby/ruby-3.1.4-r5.ebuild4
-rw-r--r--dev-lang/ruby/ruby-3.2.2-r3.ebuild4
-rw-r--r--dev-lang/ruby/ruby-3.2.2-r4.ebuild4
-rw-r--r--dev-lang/ruby/ruby-3.2.2-r5.ebuild4
-rw-r--r--dev-lang/ruby/ruby-3.3.0.ebuild4
18 files changed, 28 insertions, 28 deletions
diff --git a/dev-lang/php/php-8.2.13-r1.ebuild b/dev-lang/php/php-8.2.13-r1.ebuild
index a0aadbfbb272..84a229cfcd7a 100644
--- a/dev-lang/php/php-8.2.13-r1.ebuild
+++ b/dev-lang/php/php-8.2.13-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -118,7 +118,7 @@ COMMON_DEPEND="
tokyocabinet? ( dev-db/tokyocabinet )
truetype? ( =media-libs/freetype-2* )
unicode? ( dev-libs/oniguruma:= )
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
webp? ( media-libs/libwebp:0= )
xml? ( >=dev-libs/libxml2-2.9.0 )
xpm? ( x11-libs/libXpm )
diff --git a/dev-lang/php/php-8.3.0-r1.ebuild b/dev-lang/php/php-8.3.0-r1.ebuild
index c5abc844f96b..0ed10cd2af85 100644
--- a/dev-lang/php/php-8.3.0-r1.ebuild
+++ b/dev-lang/php/php-8.3.0-r1.ebuild
@@ -119,7 +119,7 @@ COMMON_DEPEND="
tokyocabinet? ( dev-db/tokyocabinet )
truetype? ( media-libs/freetype )
unicode? ( dev-libs/oniguruma:= )
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
webp? ( media-libs/libwebp:0= )
xml? ( dev-libs/libxml2 )
xpm? ( x11-libs/libXpm )
diff --git a/dev-lang/python/metadata.xml b/dev-lang/python/metadata.xml
index 1d85e227b848..31350aebeb2b 100644
--- a/dev-lang/python/metadata.xml
+++ b/dev-lang/python/metadata.xml
@@ -25,7 +25,7 @@
</flag>
<flag name="valgrind">
Disable pymalloc when running under
- <pkg>dev-util/valgrind</pkg> is detected (may incur minor
+ <pkg>dev-debug/valgrind</pkg> is detected (may incur minor
performance penalty even when valgrind is not used)
</flag>
<flag name="wininst">
diff --git a/dev-lang/python/python-2.7.18_p16-r1.ebuild b/dev-lang/python/python-2.7.18_p16-r1.ebuild
index e38ab82e1bd4..539f7addcb1c 100644
--- a/dev-lang/python/python-2.7.18_p16-r1.ebuild
+++ b/dev-lang/python/python-2.7.18_p16-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -66,7 +66,7 @@ RDEPEND="
DEPEND="
${RDEPEND}
bluetooth? ( net-wireless/bluez )
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
"
BDEPEND="
app-alternatives/awk
diff --git a/dev-lang/python/python-3.10.13.ebuild b/dev-lang/python/python-3.10.13.ebuild
index 6645941b2590..b71238d52f5b 100644
--- a/dev-lang/python/python-3.10.13.ebuild
+++ b/dev-lang/python/python-3.10.13.ebuild
@@ -71,7 +71,7 @@ RDEPEND="
DEPEND="
${RDEPEND}
bluetooth? ( net-wireless/bluez )
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
test? ( app-arch/xz-utils )
"
# autoconf-archive needed to eautoreconf
diff --git a/dev-lang/python/python-3.11.7.ebuild b/dev-lang/python/python-3.11.7.ebuild
index 9291c3cd5cec..d7e61dca5f92 100644
--- a/dev-lang/python/python-3.11.7.ebuild
+++ b/dev-lang/python/python-3.11.7.ebuild
@@ -72,7 +72,7 @@ DEPEND="
${RDEPEND}
bluetooth? ( net-wireless/bluez )
test? ( app-arch/xz-utils )
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
"
# autoconf-archive needed to eautoreconf
BDEPEND="
diff --git a/dev-lang/python/python-3.12.1.ebuild b/dev-lang/python/python-3.12.1.ebuild
index aa40080aa75f..1ba026283cfc 100644
--- a/dev-lang/python/python-3.12.1.ebuild
+++ b/dev-lang/python/python-3.12.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -77,7 +77,7 @@ DEPEND="
dev-python/ensurepip-setuptools
dev-python/ensurepip-wheel
)
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
"
# autoconf-archive needed to eautoreconf
BDEPEND="
diff --git a/dev-lang/python/python-3.12.1_p1.ebuild b/dev-lang/python/python-3.12.1_p1.ebuild
index 9d7497fe2e13..8b1d4b1a4837 100644
--- a/dev-lang/python/python-3.12.1_p1.ebuild
+++ b/dev-lang/python/python-3.12.1_p1.ebuild
@@ -77,7 +77,7 @@ DEPEND="
dev-python/ensurepip-setuptools
dev-python/ensurepip-wheel
)
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
"
# autoconf-archive needed to eautoreconf
BDEPEND="
diff --git a/dev-lang/python/python-3.13.0_alpha2.ebuild b/dev-lang/python/python-3.13.0_alpha2.ebuild
index 1ee5e552ed1a..35ae0c00ceb4 100644
--- a/dev-lang/python/python-3.13.0_alpha2.ebuild
+++ b/dev-lang/python/python-3.13.0_alpha2.ebuild
@@ -76,7 +76,7 @@ DEPEND="
dev-python/ensurepip-setuptools
dev-python/ensurepip-wheel
)
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
"
# autoconf-archive needed to eautoreconf
BDEPEND="
diff --git a/dev-lang/python/python-3.8.18.ebuild b/dev-lang/python/python-3.8.18.ebuild
index e836c5f1262c..6fdddf7f55e4 100644
--- a/dev-lang/python/python-3.8.18.ebuild
+++ b/dev-lang/python/python-3.8.18.ebuild
@@ -67,7 +67,7 @@ DEPEND="
${RDEPEND}
bluetooth? ( net-wireless/bluez )
test? ( app-arch/xz-utils )
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
"
# autoconf-archive needed to eautoreconf
BDEPEND="
diff --git a/dev-lang/python/python-3.9.18.ebuild b/dev-lang/python/python-3.9.18.ebuild
index 07e9633a1397..38032a975cff 100644
--- a/dev-lang/python/python-3.9.18.ebuild
+++ b/dev-lang/python/python-3.9.18.ebuild
@@ -68,7 +68,7 @@ DEPEND="
${RDEPEND}
bluetooth? ( net-wireless/bluez )
test? ( app-arch/xz-utils )
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
"
# autoconf-archive needed to eautoreconf
BDEPEND="
diff --git a/dev-lang/ruby/ruby-3.1.4-r3.ebuild b/dev-lang/ruby/ruby-3.1.4-r3.ebuild
index b82f8a54cfe5..18f137eb902a 100644
--- a/dev-lang/ruby/ruby-3.1.4-r3.ebuild
+++ b/dev-lang/ruby/ruby-3.1.4-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -44,7 +44,7 @@ RDEPEND="
DEPEND="
${RDEPEND}
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
"
BUNDLED_GEMS="
diff --git a/dev-lang/ruby/ruby-3.1.4-r4.ebuild b/dev-lang/ruby/ruby-3.1.4-r4.ebuild
index 5ac8926c11a8..01303a29648f 100644
--- a/dev-lang/ruby/ruby-3.1.4-r4.ebuild
+++ b/dev-lang/ruby/ruby-3.1.4-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -44,7 +44,7 @@ RDEPEND="
DEPEND="
${RDEPEND}
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
"
BUNDLED_GEMS="
diff --git a/dev-lang/ruby/ruby-3.1.4-r5.ebuild b/dev-lang/ruby/ruby-3.1.4-r5.ebuild
index 891c18c44ba3..c46b8cc3ce44 100644
--- a/dev-lang/ruby/ruby-3.1.4-r5.ebuild
+++ b/dev-lang/ruby/ruby-3.1.4-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -44,7 +44,7 @@ RDEPEND="
DEPEND="
${RDEPEND}
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
"
BUNDLED_GEMS="
diff --git a/dev-lang/ruby/ruby-3.2.2-r3.ebuild b/dev-lang/ruby/ruby-3.2.2-r3.ebuild
index 4bd9dd360dac..b1fe55a41716 100644
--- a/dev-lang/ruby/ruby-3.2.2-r3.ebuild
+++ b/dev-lang/ruby/ruby-3.2.2-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -44,7 +44,7 @@ RDEPEND="
DEPEND="
${RDEPEND}
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
"
BUNDLED_GEMS="
diff --git a/dev-lang/ruby/ruby-3.2.2-r4.ebuild b/dev-lang/ruby/ruby-3.2.2-r4.ebuild
index 9e0b71b55821..1f76362a0fb0 100644
--- a/dev-lang/ruby/ruby-3.2.2-r4.ebuild
+++ b/dev-lang/ruby/ruby-3.2.2-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -44,7 +44,7 @@ RDEPEND="
DEPEND="
${RDEPEND}
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
"
BUNDLED_GEMS="
diff --git a/dev-lang/ruby/ruby-3.2.2-r5.ebuild b/dev-lang/ruby/ruby-3.2.2-r5.ebuild
index ab903f449f39..f5d3691313f5 100644
--- a/dev-lang/ruby/ruby-3.2.2-r5.ebuild
+++ b/dev-lang/ruby/ruby-3.2.2-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -44,7 +44,7 @@ RDEPEND="
DEPEND="
${RDEPEND}
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
"
BUNDLED_GEMS="
diff --git a/dev-lang/ruby/ruby-3.3.0.ebuild b/dev-lang/ruby/ruby-3.3.0.ebuild
index f8b4271dfb6b..f467508bf9af 100644
--- a/dev-lang/ruby/ruby-3.3.0.ebuild
+++ b/dev-lang/ruby/ruby-3.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -43,7 +43,7 @@ RDEPEND="
DEPEND="
${RDEPEND}
- valgrind? ( dev-util/valgrind )
+ valgrind? ( dev-debug/valgrind )
"
BUNDLED_GEMS="