summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/emojis/emojis-0.1.ebuild')
-rw-r--r--dev-haskell/emojis/emojis-0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-haskell/emojis/emojis-0.1.ebuild b/dev-haskell/emojis/emojis-0.1.ebuild
new file mode 100644
index 000000000000..c070a220f9cc
--- /dev/null
+++ b/dev-haskell/emojis/emojis-0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion between emoji characters and their names."
+HOMEPAGE="https://github.com/jgm/emojis#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7 )
+"