summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cipher-blowfish')
-rw-r--r--dev-haskell/cipher-blowfish/Manifest2
-rw-r--r--dev-haskell/cipher-blowfish/cipher-blowfish-0.0.2.ebuild33
-rw-r--r--dev-haskell/cipher-blowfish/cipher-blowfish-0.0.3.ebuild33
-rw-r--r--dev-haskell/cipher-blowfish/metadata.xml11
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-haskell/cipher-blowfish/Manifest b/dev-haskell/cipher-blowfish/Manifest
new file mode 100644
index 000000000000..3500c549a50a
--- /dev/null
+++ b/dev-haskell/cipher-blowfish/Manifest
@@ -0,0 +1,2 @@
+DIST cipher-blowfish-0.0.2.tar.gz 12878 SHA256 578f6cc2718cd5169dc9c1b2745a9c6b746ad85cd182bb4efd677abb350e4c22 SHA512 2fb84d5ab9a4891646584f3a0d2beb06cb3f50c4f029a0a0f02c6609433eb95f59cb1d3e46bce6fac70bb68b27bf5d83e3fa06887aabe1d746a6e4411fdc4d17 WHIRLPOOL 1cfe77b43fbbef483dd6c3906cc1d6bc3b36aeba9f20e2d4670bd393ea842311fbc2977acd67b913aa55a22de185e060321d88acaba634e42cda84cc0b209df7
+DIST cipher-blowfish-0.0.3.tar.gz 12876 SHA256 8f41170a851dba6d0b6f07298af3213baca09ab2a8aaf2adb733631feb3b6641 SHA512 5fcccde71c1324b34e54c01c41d878150ab8db48728d1bfc21406eda58e4a363de8397f395eaa25a6fb26e4d8c95683abafe0c6bf42d7853db07d768ed245cc0 WHIRLPOOL ba74998a204e05cbe9a473849b2278b8c63a34f5a1fee7dd6aa3d7b63ad5237a03246f473580ed0ba5c92b8ff7c069595255a76e8b85a7229196042154292b25
diff --git a/dev-haskell/cipher-blowfish/cipher-blowfish-0.0.2.ebuild b/dev-haskell/cipher-blowfish/cipher-blowfish-0.0.2.ebuild
new file mode 100644
index 000000000000..d0b31d419422
--- /dev/null
+++ b/dev-haskell/cipher-blowfish/cipher-blowfish-0.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Blowfish cipher"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.3:=[profile?]
+ >=dev-haskell/securemem-0.1.2:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/crypto-cipher-tests
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
diff --git a/dev-haskell/cipher-blowfish/cipher-blowfish-0.0.3.ebuild b/dev-haskell/cipher-blowfish/cipher-blowfish-0.0.3.ebuild
new file mode 100644
index 000000000000..67b8a510973f
--- /dev/null
+++ b/dev-haskell/cipher-blowfish/cipher-blowfish-0.0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Blowfish cipher"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.3:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
+ >=dev-haskell/securemem-0.1.2:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/crypto-cipher-tests
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
diff --git a/dev-haskell/cipher-blowfish/metadata.xml b/dev-haskell/cipher-blowfish/metadata.xml
new file mode 100644
index 000000000000..9646e071edc6
--- /dev/null
+++ b/dev-haskell/cipher-blowfish/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Blowfish cipher primitives
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-crypto-cipher</remote-id>
+ </upstream>
+</pkgmetadata>