summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/phpmyadmin')
-rw-r--r--dev-db/phpmyadmin/Manifest1
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-5.2.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-db/phpmyadmin/Manifest b/dev-db/phpmyadmin/Manifest
index 7d7a27d1edea..f275ae052794 100644
--- a/dev-db/phpmyadmin/Manifest
+++ b/dev-db/phpmyadmin/Manifest
@@ -1 +1,2 @@
DIST phpMyAdmin-5.2.0-all-languages.tar.xz 7078212 BLAKE2B 184c5f1ca0d9fee4812d7f7847f7142887f39103cc629acd08183986f71a3069bfb89750c0e03f4a3a20d2ee767d37a281b14ec8d0ad50f44321620b0735023a SHA512 69658f94908e279e80f7cb76ac108090d704f27bc3f3206ff7d69c0aac4119ee42696ce66f98be6bc11e3532ca0d47916c1a2a8c915c3af6d1e5be6aa1d925a5
+DIST phpMyAdmin-5.2.1-all-languages.tar.xz 7461668 BLAKE2B bdb95b643c2ba39e406b7c8c01c071a5e8596e15570f68033a439076309c26fd444689bb0acea05ce8c47f913f0c3c30b4f593ad916d081de4b369dd6aef4573 SHA512 8b440d90d887fa0391810732cad2b4bf502f0e045324e1f159cb06e34dae4268febaef0a6a8ac0e58d0cb0f945f3497354313585f80555f199c609de378ca873
diff --git a/dev-db/phpmyadmin/phpmyadmin-5.2.1.ebuild b/dev-db/phpmyadmin/phpmyadmin-5.2.1.ebuild
new file mode 100644
index 000000000000..582e38711c9d
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-5.2.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+MY_PV=${PV/_/-}
+MY_PN="phpMyAdmin"
+MY_P="${MY_PN}-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="https://www.phpmyadmin.net/"
+SRC_URI="https://files.phpmyadmin.net/${MY_PN}/${MY_PV}/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos"
+IUSE="setup"
+
+RDEPEND="
+ dev-lang/php[ctype,filter,json(+),session,ssl,unicode]
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+ virtual/httpd-php:*
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README RELEASE-DATE-${MY_PV} ChangeLog
+ rm -f LICENSE README* RELEASE-DATE-${MY_PV}
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}