summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/ksh/ksh-1.0.0_beta2.ebuild')
-rw-r--r--app-shells/ksh/ksh-1.0.0_beta2.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/app-shells/ksh/ksh-1.0.0_beta2.ebuild b/app-shells/ksh/ksh-1.0.0_beta2.ebuild
deleted file mode 100644
index 297d09947372..000000000000
--- a/app-shells/ksh/ksh-1.0.0_beta2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="The Original ATT Korn Shell"
-HOMEPAGE="http://www.kornshell.com/"
-
-MY_PV=$(ver_rs 3 - 4 .)
-SRC_URI="https://github.com/ksh93/${PN}/archive/v${MY_PV}/ksh-v${MY_PV}.tar.gz"
-
-LICENSE="EPL-1.0"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-PATCHES=(
- "${FILESDIR}/ksh-1.0.0-beta.2-gcc12.patch"
-)
-
-src_prepare() {
- default
-
- # disable register for debugging
- sed -i 1i"#define register" src/lib/libast/include/ast.h || die
-}
-
-src_compile() {
- local extraflags=(
- "-Wno-unknown-pragmas"
- "-Wno-missing-braces"
- "-Wno-unused-result"
- "-Wno-return-type"
- "-Wno-int-to-pointer-cast"
- "-Wno-parentheses"
- "-Wno-unused"
- "-Wno-unused-but-set-variable"
- "-Wno-cpp"
- "-Wno-maybe-uninitialized"
- "-Wno-lto-type-mismatch"
- "-P"
- )
- append-cflags $(test-flags-CC ${extraflags[@]})
- filter-flags '-fdiagnostics-color=always' # https://github.com/ksh93/ksh/issues/379
- export CCFLAGS="${CFLAGS} -fno-strict-aliasing"
-
- tc-export AR CC LD NM
-
- sh bin/package make SHELL="${BROOT}"/bin/sh || die
-}
-
-src_test() {
- # test tries to catch IO error
- addwrite /proc/self/mem
-
- # arith.sh uses A for tests
- unset A
-
- sh bin/shtests --compile || die
-}
-
-src_install() {
- local myhost="$(sh bin/package host)"
- cd "arch/${myhost}" || die
-
- into /
- dobin bin/ksh
- dosym ksh /bin/rksh
-
- newman man/man1/sh.1 ksh.1
-}