summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/gcal')
-rw-r--r--app-misc/gcal/gcal-4.1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/app-misc/gcal/gcal-4.1.ebuild b/app-misc/gcal/gcal-4.1.ebuild
index da50405b5703..d5a8dbc1d9dc 100644
--- a/app-misc/gcal/gcal-4.1.ebuild
+++ b/app-misc/gcal/gcal-4.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils flag-o-matic toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="The GNU Calendar - a replacement for cal"
HOMEPAGE="https://www.gnu.org/software/gcal/"
@@ -16,15 +16,18 @@ IUSE="ncurses nls unicode"
DEPEND="
app-arch/xz-utils
- nls? ( >=sys-devel/gettext-0.17 )"
+ nls? ( >=sys-devel/gettext-0.17 )
+ unicode? ( dev-libs/libunistring:= )"
-RDEPEND="nls? ( virtual/libintl )"
+RDEPEND="nls? ( virtual/libintl )
+ unicode? ( dev-libs/libunistring:= )"
DOCS=( BUGS LIMITATIONS NEWS README THANKS TODO )
src_configure() {
tc-export CC
append-cppflags -D_GNU_SOURCE
+ use unicode && append-libs -lunistring
econf \
--disable-rpath \
$(use_enable nls) \