summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/prey')
-rw-r--r--app-laptop/prey/Manifest1
-rw-r--r--app-laptop/prey/files/prey-0.5.3-mplayer-support.patch48
-rw-r--r--app-laptop/prey/files/prey-0.5.4-cron-functions.patch28
-rw-r--r--app-laptop/prey/files/prey-0.5.4-gtk-ui.patch22
-rw-r--r--app-laptop/prey/files/prey-cron-functions.patch31
-rw-r--r--app-laptop/prey/files/prey.cron1
-rw-r--r--app-laptop/prey/metadata.xml21
-rw-r--r--app-laptop/prey/prey-0.5.4-r1.ebuild167
8 files changed, 319 insertions, 0 deletions
diff --git a/app-laptop/prey/Manifest b/app-laptop/prey/Manifest
new file mode 100644
index 000000000000..63191d5eb4c2
--- /dev/null
+++ b/app-laptop/prey/Manifest
@@ -0,0 +1 @@
+DIST prey-0.5.4-linux.zip 646891 SHA256 5d0f6f3e3a48dc5668ff82de55e202e5c28b3fab1f4d71dd55c22b8565583d7e SHA512 15e13b08dd786b3fddf39f8d0e02ceb0e2503be09ea3abde9cfc6431fb2c8388c077f2960dd82d9fb2119929274f2f57e70f642cd8cf3c6e6d76af9701c56724 WHIRLPOOL 3d7e10cfb5926a7f6a5a46c638bb859e6b4b2decb49a979f39573e8f4d2a9c66904e595c144dc4039018d567cd3810f69ef31658018ab3e2dd167ee8bcbbd114
diff --git a/app-laptop/prey/files/prey-0.5.3-mplayer-support.patch b/app-laptop/prey/files/prey-0.5.3-mplayer-support.patch
new file mode 100644
index 000000000000..970f50d751d9
--- /dev/null
+++ b/app-laptop/prey/files/prey-0.5.3-mplayer-support.patch
@@ -0,0 +1,48 @@
+--- modules/webcam/platform/linux/functions.orig 2011-01-19 22:49:55.457000055 -0700
++++ modules/webcam/platform/linux/functions 2011-01-20 18:19:11.046000085 -0700
+@@ -9,6 +9,7 @@
+
+ # do we have streamer installed ?
+ local streamer=`which streamer`
++ local mencoder=`which mencoder`
+ if [ -n "$streamer" ]; then
+
+ # take four pictures every 0.5 seconds as JPEG
+@@ -37,19 +38,32 @@
+ fi
+
+ fi
+-
++ elif [ -n "${mencoder}" ]; then
++ # not sure how to do this same thing with mencoder
++ mplayer tv:// -tv driver=v4l2:noaudio:device=/dev/video0 -frames 10 -vo jpeg &> /dev/null
++ if [ $? == 0 ]; then
++ mv 00000010.jpg "${webcam__picture}" > /dev/null
++ rm 000000*.jpg > /dev/null
++ fi
+ fi
+
+ }
+
+ capture_video() {
+
+- # we should already know if we do have streamer
++ local frames=$(( $webcam__video_capture_time * $webcam__frames_per_second ))
++
++ # do we have streamer installed ?
++ local streamer=`which streamer`
++ local mencoder=`which mencoder`
++
+ if [ -n "$streamer" ]; then
+-
+- local frames=$(( $webcam__video_capture_time * $webcam__frames_per_second ))
+ $streamer -o "$webcam__video" -f yuv2 -F stereo -r $webcam__frames_per_second -t $frames
+-
++ elif [ -n "${mencoder}" ]; then
++ ${mencoder} tv:// -tv driver=v4l2:noaudio:device=/dev/video0 -ovc lavc -ffourcc DX50 -ofps ${webcam__frames_per_second} -endpos ${webcam__video_capture_time} -o "${tmpdir}/prey-video.avi" &> /dev/null
++ if [ $? == 0 ]; then
++ webcam__video="${tmpdir}/prey-video.avi"
++ fi
+ fi
+
+ }
diff --git a/app-laptop/prey/files/prey-0.5.4-cron-functions.patch b/app-laptop/prey/files/prey-0.5.4-cron-functions.patch
new file mode 100644
index 000000000000..963b685292c7
--- /dev/null
+++ b/app-laptop/prey/files/prey-0.5.4-cron-functions.patch
@@ -0,0 +1,28 @@
+Index: prey/core/functions
+===================================================================
+--- prey.orig/core/functions
++++ prey/core/functions
+@@ -194,12 +194,12 @@ get_delay_for(){
+
+ get_current_delay(){
+ # crontab -l | grep prey | sed "s/^..\([0-9]*\).*/\1/"
+- crontab -l 2> /dev/null | grep prey | head -1 | sed 's/ \/.*//'
++ sed -i 's/ \/.*//' /etc/cron.d/prey.cron
+ }
+
+ update_execution_delay(){
+ local full_path=$(full_path "$base_path")
+- (crontab -l 2> /dev/null | grep -v prey; echo "${1}" "${full_path}/prey.sh > /var/log/prey.log 2>&1") | crontab -
++ echo "${new_delay}" "/usr/bin/prey.sh > /var/log/prey.log" > /etc/cron.d/prey.cron
+ }
+
+ # if device is missing we'll make sure the current delay matches the one
+@@ -273,7 +273,7 @@ verify_installation(){
+ log " !! Cron daemon not found! Try running it with 'sudo /etc/init.d/cron start'."
+ fi
+ log " -- Checking for crontab entry..."
+- local result=`crontab -l | grep 'prey.sh' | wc -l 2> /dev/null`
++ local result=`wc -l /etc/cron.d/prey.cron 2> /dev/null`
+ if [ "$result" -gt 0 ]; then
+ log " -- Found!"
+ else
diff --git a/app-laptop/prey/files/prey-0.5.4-gtk-ui.patch b/app-laptop/prey/files/prey-0.5.4-gtk-ui.patch
new file mode 100644
index 000000000000..6a50a4e0426e
--- /dev/null
+++ b/app-laptop/prey/files/prey-0.5.4-gtk-ui.patch
@@ -0,0 +1,22 @@
+Index: prey/platform/linux/prey-config.py
+===================================================================
+--- prey.orig/platform/linux/prey-config.py
++++ prey/platform/linux/prey-config.py
+@@ -23,7 +23,7 @@ import base64
+
+ app_name = 'prey-config'
+ lang_path = 'lang'
+-script_path = os.sys.path[0]
++script_path = '/usr/share/prey/platform/linux/'
+
+ ################################################
+ # gettext localization
+@@ -42,7 +42,7 @@ _ = gettext.gettext
+ ################################################
+
+ PREY_PATH = '/usr/share/prey'
+-PREY_CONFIG_FILE = PREY_PATH + '/config'
++PREY_CONFIG_FILE = '/etc/config'
+ PREY_COMMAND = PREY_PATH + '/prey.sh > /var/log/prey.log 2>&1'
+ CONTROL_PANEL_URL = 'http://control.preyproject.com'
+ CONTROL_PANEL_URL_SSL = 'https://control.preyproject.com'
diff --git a/app-laptop/prey/files/prey-cron-functions.patch b/app-laptop/prey/files/prey-cron-functions.patch
new file mode 100644
index 000000000000..0e5486d27d9b
--- /dev/null
+++ b/app-laptop/prey/files/prey-cron-functions.patch
@@ -0,0 +1,31 @@
+Index: prey/core/functions
+===================================================================
+--- prey.orig/core/functions
++++ prey/core/functions
+@@ -170,7 +170,7 @@ remove_files(){
+
+ get_current_delay(){
+ # crontab -l | grep prey | sed "s/^..\([0-9]*\).*/\1/"
+- crontab -l | grep prey | head -1 | sed 's/ \/.*//'
++ sed -i 's/ \/.*//' /etc/cron.d/prey.cron
+ }
+
+ get_delay_for(){
+@@ -197,7 +197,7 @@ get_delay_for(){
+
+ update_execution_delay(){
+ local full_path=`full_path "$base_path"`
+- (crontab -l | grep -v prey; echo "${new_delay}" "${full_path}/prey.sh > /var/log/prey.log") | crontab -
++ echo "${new_delay}" "/usr/bin/prey.sh > /var/log/prey.log" > /etc/cron.d/prey.cron
+ }
+
+ ####################################################################
+@@ -250,7 +250,7 @@ verify_installation(){
+ log " !! Cron daemon not found! Try running it with 'sudo /etc/init.d/cron start'."
+ fi
+ log " -- Checking for crontab entry..."
+- local result=`crontab -l | grep 'prey.sh' | wc -l 2> /dev/null`
++ local result=`wc -l /etc/cron.d/prey.cron 2> /dev/null`
+ if [ "$result" -gt 0 ]; then
+ log " -- Found!"
+ else
diff --git a/app-laptop/prey/files/prey.cron b/app-laptop/prey/files/prey.cron
new file mode 100644
index 000000000000..fe036185a2d5
--- /dev/null
+++ b/app-laptop/prey/files/prey.cron
@@ -0,0 +1 @@
+#*/20 * * * * /usr/bin/prey &>/dev/null
diff --git a/app-laptop/prey/metadata.xml b/app-laptop/prey/metadata.xml
new file mode 100644
index 000000000000..a2c028af4292
--- /dev/null
+++ b/app-laptop/prey/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name="alarm">Module for playing an audio file</flag>
+ <flag name="alert">Display a warning message when the computer seems to be stolen"</flag>
+ <flag name="geo">Module for retrieving the physical location of the stolen computer</flag>
+ <flag name="lock">Lock stolen computer</flag>
+ <flag name="network">Get network information (active connections, traceroute) from stolen computer</flag>
+ <flag name="secure">Delete or hide sensitive user data</flag>
+ <flag name="session">Get screenshots from user session</flag>
+ <flag name="userpriv">Create a prey user group so regular users can access and modify the prey configuration. Use it with caution</flag>
+ <flag name="webcam">Use computer's webcam to take screenshots of the thief</flag>
+</use>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/app-laptop/prey/prey-0.5.4-r1.ebuild b/app-laptop/prey/prey-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..40077d72216f
--- /dev/null
+++ b/app-laptop/prey/prey-0.5.4-r1.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils readme.gentoo user
+
+DESCRIPTION="Tracking software for asset recovery"
+HOMEPAGE="http://preyproject.com/"
+SRC_URI="http://preyproject.com/releases/${PV}/${P}-linux.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gtk userpriv"
+
+LINGUAS="en it sv es"
+for x in ${LINGUAS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+MODULES="+alarm +alert +geo lock +network secure +session webcam"
+IUSE="${IUSE} ${MODULES}"
+
+DEPEND=""
+#TODO: some of these deps may be dependent on USE
+RDEPEND="${DEPEND}
+ app-shells/bash
+ virtual/cron
+ || ( net-misc/curl net-misc/wget )
+ dev-perl/IO-Socket-SSL
+ dev-perl/Net-SSLeay
+ sys-apps/net-tools
+ alarm? ( media-sound/mpg123
+ media-sound/pulseaudio
+ )
+ alert? ( || ( ( gnome-extra/zenity ) ( kde-apps/kdialog ) ) )
+ gtk? ( dev-python/pygtk )
+ lock? ( dev-python/pygtk )
+ network? ( net-analyzer/traceroute )
+ session? ( sys-apps/iproute2
+ || ( media-gfx/scrot media-gfx/imagemagick )
+ )
+ webcam? ( || ( ( media-video/mplayer[encode,jpeg,v4l] ) ( media-tv/xawtv ) ) )"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ if use userpriv; then
+ enewgroup ${PN}
+ fi
+ if use gtk; then
+ ewarn "You have the 'gtk' useflag enabled"
+ ewarn "This means that the ${PN} configuration"
+ ewarn "will be accessible via a graphical user"
+ ewarn "interface. This may allow the thief to alter"
+ ewarn "or disable the ${PN} functionality"
+ fi
+}
+
+src_prepare() {
+ DISABLE_AUTOFORMATTING="yes"
+ use userpriv && has_version "${CATEGORY}/${PN}:${SLOT}[-userpriv]" && FORCE_PRINT_ELOG="yes"
+ ! use userpriv && has_version "${CATEGORY}/${PN}:${SLOT}[userpriv]" && FORCE_PRINT_ELOG="yes"
+
+ DOC_CONTENTS="--Configuration--
+Make sure you follow the next steps before running prey for the
+first time.
+"
+
+ if use userpriv; then
+ DOC_CONTENTS+="- Add your user to ${PN} group using:
+# gpasswd -a <your_user> ${PN}"
+ else
+ DOC_CONTENTS+="You don't seem to have 'userpriv' enabled so
+${PN} configuration is only accessible as root"
+ fi
+
+ DOC_CONTENTS+="
+- Create an account on http://preyproject.com/
+- Modify the core and module configuration in /etc/prey
+- Uncomment the line in /etc/cron.d/prey.cron"
+
+ # remove system module since it depends on hal and we don't
+ # have hal in portage anymore
+ rm -rf "${S}"/modules/system || die
+
+ epatch "${FILESDIR}"/${P}-cron-functions.patch \
+ "${FILESDIR}"/${P}-gtk-ui.patch \
+ "${FILESDIR}"/${PN}-0.5.3-mplayer-support.patch
+ sed -i -e 's,readonly base_path=`dirname "$0"`,readonly \
+ base_path="/usr/share/prey",' \
+ "${S}"/prey.sh || die
+ # Fix base path. Bug #438728
+ sed -i -e "/readonly/s:base_path=.*:base_path=/usr/share/${PN}:" \
+ prey.sh || die
+}
+
+src_install() {
+ # Remove config app if -gtk
+ if use gtk; then
+ # fix the path
+ doicon "${S}"/pixmaps/${PN}.png
+ newbin "${S}"/platform/linux/${PN}-config.py ${PN}-config
+ make_desktop_entry ${PN}-config "Prey Configuration" ${PN} \
+ "System;Monitor"
+ else
+ rm -f "${S}"/platform/linux/prey-config.py || die
+ fi
+
+ # clear out unneeded language files
+ for lang in ${LINGUAS}; do
+ use "linguas_${lang}" || rm -f lang/${lang} modules/*/lang/${lang}
+ done
+
+ # Core files
+ insinto /usr/share/prey
+ doins -r "${S}"/core "${S}"/lang "${S}"/pixmaps "${S}"/platform "${S}"/version
+
+ # Main script
+ newbin ${PN}.sh ${PN}
+
+ # Put the configuration file into /etc, strict perms, symlink
+ insinto /etc/prey
+ newins config ${PN}.conf
+ # some scripts require /usr/share/prey/config file to be present
+ # so symlink it to prey.conf
+ dosym /etc/${PN}/${PN}.conf /usr/share/${PN}/config
+ use userpriv && { fowners root:${PN} /etc/prey ; }
+ fperms 770 /etc/prey
+ use userpriv && { fowners root:${PN} /etc/prey/prey.conf ; }
+ fperms 660 /etc/prey/prey.conf
+
+ # Add cron.d script
+ insinto /etc/cron.d
+ doins "${FILESDIR}/prey.cron"
+ use userpriv && { fowners root:${PN} /etc/cron.d/prey.cron ; }
+ fperms 660 /etc/cron.d/prey.cron
+
+ dodoc README
+
+ # modules
+ cd "${S}"/modules
+ for mod in *
+ do
+ use ${mod} || continue
+
+ # move config, if present, to /etc/prey
+ if [ -f $mod/config ]
+ then
+ insinto "/etc/prey"
+ newins "$mod/config" "mod-$mod.conf"
+ use userpriv && { fowners root:${PN} "/etc/${PN}/mod-$mod.conf" ; }
+ fperms 660 "/etc/${PN}/mod-$mod.conf"
+ # Rest of the module in its expected location
+ insinto /usr/share/prey/modules
+ doins -r "$mod"
+ if [[ $mod == "lock" ]]; then
+ fperms 555 \
+ "/usr/share/${PN}/modules/lock/platform/linux/${PN}-lock"
+ fi
+ fi
+ done
+
+ readme.gentoo_create_doc
+}